How to select visable (front) faces only?

Most 3D apps give you the option to only select visible faces and ignore those at the back of a model, but I can’t work out how to do that in Rhino. I often want (need) to select several front surfaces only without selecting through the object and grabbing faces on the far side. Is there a way to do this?

There is the SelVisible command.

I’m aware of that command but it always seems to select surfaces/faces on the opposite side of the model. I think it’s meant to be used to avoid selecting complete objects like if a cube is in front of a sphere, then SelVisible will only select the cube. I’m talking about items belonging to the same object. I want to be able to click select, or drag a rectangle around components without selecting those on the back of the model - ie only those items with their normals facing the camera.

There’s the CullControlPolygon command or have you tried using the selection filter?

Unfortunately CullControlPolygon only toggles the display of surface or mesh “control points” - a handy command to know none the less and one I didn’t know about. As for selection filtering, I can’t find any filters that do what I want. I’m after the same functionality as “Ignore back faces” in other 3d apps like 3ds max, cinema 4d and no doubt others.

I know that in rhino we’re not working with “faces” specifically but when making selections using selection rectangle (either window or crossing mode) it would be nice if that process could be told to ignore anything behind the surfaces facing the camera (ie visible to it).

Ya good point. Seems strange that there isn’t a native way to select faces in Rhino since it does have the ability to work with meshes too.

There’s cull backface in the display options but it sill lets you select backfaces.

I was sure I’ve done it before but I must have been thinking of the T-Splines paint tool.

Hi Xen - does this mean occluded by other objects or facing away, or both ? I think in general you want to select faces for which the normal is pointing more towards than away from the current camera, correct? So, (occlusion apart) solids would always be selected; what about open objects that have some normals facing and some away, do these count as facing?


Hi Pascal, I mean facing away from the camera to the point that they are not visible to the viewport camera. So, that might include faces that face left, right, up or down and of course directly away from the camera. Essentially I want to ignore anything I can’t see in the viewport like edges, points, faces or even other separate objects which are behind and occluded by the object I’m working on. I know I can exclude the separate objects, there’s a command for that, but it seems excluding the other elements (sub-elements) is different.

There’s a viewport display mode called Hidden Line (i think), which culls everything that can’t be seen by the camera. I was hoping there was a way to tell rhino to ignore these same elements when I use window or crossing selection. If you have used other polygonal modeling apps, you would recognize what I’m talking about because they all seem to have a command that does exactly that - the command is called Ignore Backfaces, or something similar, and it prevents you from selecting anything that cannot be “seen” from your current view - points, faces, edges, other objects.

The main reason for wanting this feature is because when I import a mesh (obj, stl, fbx etc) they always seem to have a million tiny faces & edges and trying to select just a few that are on the front side and ignoring those on the back is incredibly tedious and renders the window/cross selection method completely useless.

I hope that helps explain what I’m after. If there isn’t a command that allows this, maybe it’s my workflow that needs to change, but I don’t know how.


CullControlPolygon + hold the alt key when selecting.

Sorry this is a little late. lol


Sorry my bad. That is for T-Splines not regular Rhino. Have you tried importing the mesh to T-Splines?

Hi All,
Is this topic surted out. I’m having the same problem as @Xennon.

Best regards

Is this specifically for mesh objects, like it was for Xennon?
If so, does it help to turn on the points and then HidePt those parts that you don’t want to see?

Is this specifically for mesh objects, like it was for Xennon?

No that’s the only difference in this case, =)
Is there a way to select the surfaces in a file that is visible from the camera perspective?
Like when I look at an object in perspective view, I only what to select the surfaces that I see at the moment.
Same thing for if I am in top view etc.

Sorry if the questioning is badly fomed.

Best regards

Then you’ll have to explain what’s not working for you with the Selvisible command.

On the part below from this specific view: If i use selVisible it will still select the surfaces on the back side of the object eventhough it’s single surfaces.
Probably I’m doing something wrong, but in that case please tell me the correct way of doing this.

Best regards

Can you please post the part in question in a file saved with the view you want? --Mitch

I never did get a solution to this problem. I don’t think Rhino behaves like other 3d apps when it comes to hiding unseen objects/components. Glad to see I’m not the only one that wants this feature included/explained/fixed in Rhino.

Untitled.3dm (132.3 KB)

Like this one?
Best regards

We don’t ALL use Rhino 6 - yet. Might be a good idea to post files that are in the “current” version of Rhino if you want the most people to see it and open it.

6 is current! =)


As far as I can see SelVisible is completely broken…


1 Like