How to remove Coordinate near Arrow cursor?


I looked around and couldn’t find a solution. Please help!

I have rhino5 for Mac.
Here is the issue, every time I am moving my cursor, the coordinates of where my cursor is, appears next to it. It makes it very difficult to work.
I can’t easily snap on a curve to find midpoint or else.
How can I turn this option off?

Thank you so much for your help!

That should be in Preferences > ModelingAids > Cursor Tooltips : uncheck “Point”.

HTH, --Mitch

Hi Mitch

Thank you so much for your help and quick response!
It worked!
But now I have another issue…Maybe you know the answer to this one too…
In the rhino version I had before, when I was doing a polyline for example, and I wanted to add a polyline in the middle, or at the end, the cursor was immediately grabbing the right point, now it feels like I have to search and it is not stable.
I really have to zoom in and be patient to find the right point, it is so frustrating. Do you know what option it is?

Thank you again!

You might want to see if changing the snap radius under Preferences > Modeling Aids > Object snaps > Snap radius helps. Also, (but not sure if that is what you run into) do not have all Osnaps on all the time.

Check your Osnaps to see in any are on, either in Persistent or One-off …

or from the sidebar …

Thank you all for your help! It is now fixed
The radius needed to be changed!

Thank you!!

And like Wim says,

Look here …