How to print proper line width in technical display mode?


(Ormallen) #1

Pic1: This is what I see in layout, and this is good for me:


Pic2: This is what i get after printing - lines are too thick:

How can I make print output match layout view?
This are my settings of printing:

And settings of lines in tecnical display style:


(Diego Krause) #2

Have you tried with this values? maybe scaling by 0.5
Diego


(Ormallen) #3

Diego, yes, i’ve tried different values there - it seems they don’t have any effect at all - they affect only objects that belong to layout itself, not to the model.


(Diego Krause) #4

I were testing some things and actually in my case is hard to get thicker lines haha but you can try with PrimoPDF ( virtual printer ) and use the export command from rhino instead of Print, the box dialog is practically the same but with other options.


(Ormallen) #5

i can’t export detail view with detail image inside it…


(Diego Krause) #6

neither with raster output? the technical view is just a representation, not vector geometry i guess


(Ormallen) #7

Unfortunately, raster neither works.


(Ormallen) #8

Or may be is there some other practic to get technical-like looking drafts without using Make2d (i want my drafts to stay connected with model and update in case of model change)?


(Diego Krause) #9

I think there is no linked drawings in Rhino, maybe on a parametric program.
This test was using the PrimoPDF as I mentioned, it’s free and works as a virtual printer


(Ormallen) #10

Can you control line width there?


(Diego Krause) #11

I have the opposite problem! can’t get thicker lines
Tried with 10 pixels on each pen configuration, scale factor line width and so on
opposite%20problem


#13

Printed line weights in Rhino are either a per object or per layer setting. They don’t pay attention to display settings. If you look at your layer pallet you should see where you need to set the print width:

The per detail settings will let you override the global settings for weight, color, visibility, and linetype on a per detail basis. You need to make the detail active before you change these settings, otherwise you will be changing the weight, color, visibility, or linetype for that layout sheet, not the detail itself.

You can also use PrintDisplay to preview what your lineweights will look like.

Sam


(Ormallen) #14

Thank you, but it didn’t work.


#15

What display mode are you using in your detail? I see earlier in the thread you were recommended to use a technical mode, are you using this or somethings else? What are the heavy weight objects, are they lines, or surfaces that are getting clipped, or…? I would also be curious to see what your global lineweights are set to, not the per detail you show in your image.


(Ormallen) #16

I use technical display mode. All objects are polysurfaces whithout clipping. Lineweights are mostly default and hairline.


(Diego Krause) #17

have your video drivers up to date?


#18

Ah, yes. Unfortunately technical mode does not play well with printing. Technical seems to be treated as a visual trick, and not an actual drawing tool. I think if you want a parametric hidden line drawing, you might have to look at things like SectionTools or VisualArc

Sam


(Pascal Golay) #19

Hello - can you please try setting the display mode to not show hidden lines - does the print look better?

-Pascal


#20

Teying to get a technical drawing out without hidden lines. Ok. MY suggestion: Export to a real CAD program where this has all been solved already.