How to prevent layers turning on when pasting a block?

Hello! I have a bunch of blocks in my model and they all have a point on it’s insert.

I normally have that point’s layer turned off cause they’re just so many that I can’t hardly see the model.

Unfortunately each time I paste a block (I guess from a document where I’m working with that layer visible) that layer is turned on automatically.

I don’t want to be constantly turning layers on and off.

Is there any settings that can change this behavior?


Hi -
I might be missing something here (attaching files always helps reducing the amount of guesswork involved) - that doesn’t seem to be unique for blocks. When you paste an object from a different file into a current file where the layer that that object resides on is off, the layer will always be turned on.
There is no setting to change that behavior.

Here’s a thing that might work for now - (758 Bytes)

To use the Python script use RunPythonScript, or a macro:

_-RunPythonScript "Full path to py file inside double-quotes"



This makes it impossible to organize large projects!
Imagine working with blocks that contain speciality layers like this!?

Rhino already has terrible block management and now this?

You realize this is a working tools that effects plots of people, not just some game you have hundreds to choose from!

Do you even do any development going on these “problems” or you just add stuff on top of it?

Wink if Autodesk threatening you? :wink:

thanks for the script anyway.
I already lost most of my settings due to the “managing settings when multiple instances running” problem.
would surely be nice if you could develop better “settings serialiazation” to deal with all the scripts :slight_smile: