How to pick points correctly

Uploading: WhatsApp Video 2020-11-18 at 11.08.00 AM.mp4…

Hi - your video didn’t upload in this message.
In the other message with the same title that you posted and deleted, the video was hard to follow but showed something like the following situation:

You are not in any way describing what the issue is with that so I’ll just guess that you want to actually snap to the endpoint that is not on the CPlane.

Go to Rhino Options > Modeling Aids > Object snaps and turn off Project object snaps to CPlane.
-wim

its picking bottom and mid points only… how to pick top of lines points.

Its not Picking top points.Its picking only bottom points…How to pick points correctly.

Did you turn off that option that I mentioned?
-wim