How to make sure I am using all or the max amount of RAM


#1

I recently bought a machine with 32 GB finally and wish to know if there is a cap Rhino or Windows places on the amount of RAM that Rhino can use. Is there a way to increase this and/or can i check the current usage anyway?

Thank you.


#2

I don’t think there’s a cap, I’ve used up to around 24 on a 32 gig machine. You can always check your memory use at any given time with Taskmanager. Windows 8 x64 cap is 128 on the standard edition, 512 on Pro or Enterprise. --Mitch


(David Cockey) #3

Memory use by Rhino is shown at the bottom of the Rhino window towards the right side. Keep in mind that Rhino only uses the amount of memory it needs, so frequently it will only use a small fraction of available memory.

Also, some older and/or low cost versions of Windows limit the maximum amount of memory which can be used by anything.


#4

Thank you for your replies.

Currently I am only using roughly 10 GB of ram on a large file; however, it is running slow when I have my clipping plane and 3d furniture on. I figured that upgrading from my previous 16 GB of ram from my MBP to an HP Zbook 32 GB ram with NVida quadro GPU, I would see a significant difference in performance. This is not the case. Is there something I am missing? Rhino seems to not engage the power my computer has available for some reason.


(David Cockey) #5

Memory is used for short term data storage. Rhino and any other software only uses as much as it needs. In some respects it is like doing calculations and writing intermediate results on a chalkboard. As long as there is sufficient space on the chalkboard switching to a larger chalkboard won’t speed up the calculations.


#6

People often associate “running slow” with CPU and RAM when in fact, 95% of the time, when someone says “Rhino is running slow”, it’s the dynamic display performance which is perceived as “slow”. In that case, the solution (if there is one) is to be found on the video card side, as this is what affects display performance.

However, just getting a better video card does not automatically mean you will get better display performance either, there are also some Rhino display engine deficiencies that can cause bottlenecks even with a very good video card.

–Mitch


#7

Thanks for clearing that up. I assumed that having a Nvidia Quadro 2100 would mitigate any panning issues. I also had a the m3800 before and with both I notice slow panning in complex scenes especially when the clipping plane is enabled.

What sort of Rhino deficiencies could be causing this? Do you happen to know of any way to adjust them?

Thank again,
Erik


#8

Also this is a peculiar condition. It seems like anti-aliasing of some sort. It is happening on a very small model about 13 inches by 5 inches with .06 in struts. Not sure why I am having this issue with my upgraded video card. Any ideas? I have tried multiple tolerances.


(Willem Derks) #9

Hi Erik,
Are these objects overlapping?
Could it be these object are far away from the origin?
Are there other object sin the scene far way from these objects?

In any case, if you can isolate these objects showing the issue and post them in a Rhino file here, it’s much easier to find the cause, as others can have a look and test on their machine.

-Willem


#10

I forgot that the distance from the origin could cause these issues. Moved it back and now all is good. I appreciate the response!