How to make invisibility isocurves of newly created extrude and new cylinder

In the options of my program
General >>
Show surface curves >>
Show not.

Nevertheless, something similar to the isocurves always appear on the newly created extrude and new cylinder. Always in the direction V coordinate of surface.

Every time to remove the visible isocurves I have to use a _Explode and _Join commands.

Which way I need to go to invisible isocurves of newly created extrusion?


Hi Leex - the seam edge of a cylinder or other closed surfaces will show even if isocurves do not - is that what you mean?


It’s probably because you are using Extrusion objects and they display differently.
Try _UseExtrustions > Polysurfaces. With that setting all newly created objects will not be extrusions and display without extra seam, so no need to explode/join.



This is the standard cylinder. ! _Cylinder _Pause _Diameter
All other objects are created without isocurves.
The problem only with cylinder and extrusion.

Although the properties of the cylinder is called as ekstrusion ( Type object - closed extrusion)

And if I show the isocurves, then there are additional isocurves on coordinate U.

It worked :blush:


Yes, but it defeats the purpose of extrusion objects :grin: .

If you go to Rhino Options > View > Display Modes and then the display mode that you are using - probably standard Shaded. On the main page for the display mode, there is a Visibility section. The first checkbox here is for Show isocurves. If you uncheck the box, the display of the extrusion objects will be as you want.

That turning off isocurve visibility in the object properties box does not work for the extrusion objects looks like a bug to me - which is fixed in the RH6 WIP.


I often use T-splines.
If you turn off isocurve in display mode, you can not see T-splines edge.
The plugin uses option of isocurve for show edge.

It takes property only from the U coordinate

That sounds a bit like a T-splines bug then…

There are several options:

  • live with the rhino bug
  • live with the T-splines bug
  • don’t use extrusions
  • use a modified shading display mode when modelling without T-splines
  • use regular shaded mode but apply a custom display mode to T-spline objects (using -SetObjectDisplayMode)


I really liked this version

By the way I have long wanted to ask.
When I create a cylinder ! Cylinder
or circle ! _Circle, the end is always located on the X axis.

What I should be done to end always positioned vertically along the Z-axis or Y-axis when the horizontal position?

If you place a circle or cylinder by clicking with the mouse, the start / end point will be where you click - not necessarily on the X-axis. Of course, that’s a bit unpractical when making an object with an exact dimension.

There is no way to make the start / end always point in a certain direction.


  • make a circle with mouse-only input and then run ModifyRadius on it.
  • make the object and rotate
  • make a macro that does the above automatically

The question, though, is why is this important?
(my own reason for wanting these on the X-axis is that when using my default clipping planes on the X-axis, cylindrical cavities won’t show the surface seam.)

I work usually with symmetrical objects (jeweler)
Sometimes I forget to turn the circle into 90 degrees.
And if a lot of modeling arise many mistakes.
I have to redo the work.

Macro is good if I always a create a circle in only one projection.

It turns out only the script. Where should be registered for all properties of the projections?