How to make an object white in shaded/ghosted view?

view

(Chris) #1

Hi -

I create architectural/sculptural models for an artist’s studio. I don’t know much about rendering, so I will often create “realistic” colored models just using layer color settings and shaded view. This is limited but good enough for our purposes.

My problem is, I frequently need to make objects appear white. In shaded view, white layers are grey with white edge lines. I have had some success by changing white objects to a white material and turning off diffuse lighting, making the objects bright white. I also had to create a custom view mode using rendered settings but showing edges. I then use SetObjectDisplayMode for the objects that need to be white and they look pretty good.

Using this approach, however, becomes limited when changing a display mode to something other that shaded. Like if I change to Ghosted, then the white objects are still opaque.

It would be really nice if there were an easy way to make an object look white in Shaded and Ghosted mode without having to resort to trickery.

Thanks!

  • Chris at Tom Sachs Studio

(Pascal Golay) #2

Hi Chris - try the ‘Arctic’ display mode. Does that do it?
Ah - sorry - mac forum -, I did not notice that - it’s not in Rhino for mac yet.

Try rendered mode and a white material with diffuse left on but some slight (i.e. dark) emission color.
Firing up the mac now to make sure…

-Pascal


(Chris) #3

Thanks Pascal.

To clarify what I need, I like how shaded display mode works for all colors except for white. If i were designing an object with, say, bare wood, concrete, and red paint, I would just choose the closest color to represent each material (tan for wood, gray for concrete, etc). But when I need to include white objects as well as colored, it’s not as easy to represent this.

Rendered mode offers a lot more control but requires a lot of messing with Materials Editor. I love the speed and simplicity of working with shaded mode and layer colors to do quick mockups.

Perhaps the thing that I want to do is not yet possible but I wanted to put this thought/question out there.

Arctic mode looks really cool and I hope it makes it to Mac version soon!

Thanks again!


#4

Well, you can imagine that in shaded mode, if objects are 100% white on the screen, you will not be able to see any lighting effects, thus any 3D effect will be lost.

To make stuff look “whiter” as a quick fix I usually use SetObjectDisplayMode and set the object(s) in rendered mode (the rest of the scene can be in shaded still), then apply a custom material that is stock white, with 0% reflection or gloss, and I turn on “emission color” in the material and set it to some low-but-not-black value - like 30,30,30. You get something that looks like this:

Also, I don’t know how much you can monkey with display modes in Mac Rhino, but it’s possible to create a display mode that’s similar - display mode materials don’t have an emission setting as object materials do, but they do have a luminosity setting. Here is a custom display mode (V6, Windows) that “lights up” object colors, luminosity set at 25%.

LuminousShaded.ini (12.4 KB)

Oh, also for black, don’t use RGB 0,0,0 - use RGB 1,1,1 - you’ll get a real black.

I really don’t know much about this stuff, I just mess around from time to time if I need something special…


(Chris) #5

Thank you Helvetosaur. Based on your suggestions I found some display mode settings that I had not messed with before and was able to get the result I wanted! It will take some tweaking with regards to how I set up my layer colors but I think it will work. Thank you!