How to load images in Grasshopper?

The big thing with BIM is that M stands for Modelling instead of Management.

Meaning … that if we accept (in theory) that the BIM surface works: classic drawings are just by-products due to a consolidated 3d Model (a vast hierarcy of Models in fact) related with all AEC disciplines blah blah … the core of the matter is dealing with object meta-data: and that is exactly were the whole approach falls in pieces: name me any AEC BIM app that can effectively collaborate with classic RDBMS (not xml jokes)… that (1) take into account CSI (MasterFormat etc) type of specs/articles, (2) existed mainstream or custom components/solutions, (3) real-life cost data, (4) design variations, (5) bottom to top design methods …continue until the end of time

Other than that in the classic study pipeline (preliminary to final etc etc) parametric plays some (if any) role at the very early stages: the more the design goes real-life and pragmatic … the more you discover that absolutely nothing has changed from the old mouse driven days (other than the fact that you are trapped into a dangerous illusion of doing things right).

But the good news are that hope dies last.

1 Like

Well first let’s continue in private since our conversation have changed a lot, and by that way we will not create confusion to other members.

Just answering your question:
1- Autodesk approach to BIM, beside its bad program design is and will cause more harm than good for the AEC industry.
2- BIM although is an old school, real investment in it as a technology didn’t start to be taken serious but after 2005, so until now we can say that the technology haven’t grown up to maturity, even if we want to implement the one model have it all, neither our computers nor algorithms can withstand such amount of data in real life project.
3- Here is the biggest flaw that no body wants to address, it’s better to have many BIM programs that each is specialised in one or two tasks and do it perfectly and can collaborate with others than to have one do it all and failing miserably.

For the simple reason that the tools that will be used by the different actors will need to fulfil different needs and many times they are opposite to each other.

1 Like

Hi everyone,
I have few questions about working with series of small size bitmaps:

  1. How can I load a bitmap in grasshopper that no longer need file path?

  2. How to initialize series of bitmaps with names and indices and load bitmaps in grasshopper canvas without any need to charge the route even on another computer? (Works like a component by coding, decoding and initializing bitmap data with name and indices!)

I tested many ways and used existing grasshopper plugins and components (firefly, squid, image sampler,…) but neither of them worked!

Hi! I have a question about the script you wrote

I inserted the bitmap (by clicking on the add bitmap toggle) I want to preview in rhino, but it doesn’t appear in my viewport and I don’t understand why it doesn’t.
The arrows appear (and the white rectangle)

loaded%20bitmap , but the image itself doesn’t.
Also the bitmaptable content details appear to be empty… So I guess I did something wrong about inserting the bitmap?
Also the bitmap that was in the example doesn’t appear (but I guess that’s because I don’t have that file saved on my computer.

Any idea what I am doing wrong and how to solve it?
Thanks in advance!

Well … I can hardly recall details on that C# … but:

  1. Does it work exactly as posted for Nader? (it should since he reported no issues).
  2. Pack everything that you are using and post here the case.

Yes, that’s why I am thinking I did something wrong…
I tried it with all the 3 versions, the first one and the updated ones, all with the same result
Unfortunately, I can’t add a bmp file to my post (it is a non-authorized type of file), so I can’t send it. But I added a jpeg.[other bmp implemented than example.gh|attachment]

I couldn’t upload the bmp with this post (it is a non-authorized kind of file apparently), so I zipped my bmp together with the grasshopper file in this map.

Nieuwe map.zip (3.9 MB)

Thanks in advance!

OK, I’ll investigate your stuff this afternoon (BTW: by yes you mean that it works OK as posted for Nader?).

In the mean time I tested the 3 C# modes (V1C build) against some proper stuff (related with Homer) in rendered Views and everything works OK.



BTW: As admin try a jpg format from some other partition/directory: still you got bananas? (if so is surely a matter of Karma).

No, yes that I tried to do it with your versions, but no it didn’t work unfortunately… :slight_smile:
Thanks!

A jpeg also doesn’t work, it gives following error: (it says that the 'image reference is not part of of the set object)

That’s quite odd (here’s what line 158 does)

Here’s the supported formats:

More this afternoon (NOTE: all that in R5, I don’t work with R6).

Well … I have some good news: everything appears working 100% OK … meaning that these are in fact bad news (for you).



BTW: I don’t expect to have any impact … but the gh def in your zip is an older build: V1C is the latest.


The ugly news are that I don’t know what to investigate (other than Karma).

Not sure if this helps, but I have recently developed AutoEntourage to quickly load batches of .png images into Rhino using Grasshopper.

Feel free to let me know if you’d like to see finer-grain user control, and I will add it to my to-do list.

Cheers.

1 Like