How to kill your project file? (Dangerous Bug!)

I started a new Rhino session, selected my project file from the welcome window and got the question “Do you want to save Untiteled?”. OK, no problem, why not and I pressed yes. The command tell me "File successfully saved as D:…\ProjectFile.3dm. Wow, 1,5GB project file is overwritten with an empty Rhino file.
I’m glad that I tried to open an older incremental saved file only. It’s not really needed. But this is really dangerous. Please fix it so fast as possible.


1 Like

Hi Micha - thanks for the report - was this V6?
Never mind, Micha, I can reproduce this. thanks.
RH-60808 File overwritten with a blank on startup
@Micha , this seems to be hard to reproduce on demand… I did get it to happen the very first time I tried, but I cannot seem to get it to happen again - does it happen every time for you, and if so what is the exact sequence of clicks or inputs?


1 Like

It’s at V6 and I happen with a project file. Later I tried it with an other file and it happen again.

I tested it now again and it happens too. Quite chaotic:

  • start Rhino 6
  • select project from the start screen
  • I will be ask to save Untitled … yes
  • this time I got a dialog which ask to open a file … cancel
  • project file “Video Texture …” is overwritten with the empty file

Micha, can you repeat this is Vray is not enabled?


Yes happened to me too in 2017. Had worked on a project for a week. I going send the file on Friday morning, but to my shock I had managed to overwrite it with an empty file. Must have been in the same way as Micha describes. :pleading_face:
Luckily I managed to rebuild the model very fast that day and send it to the client.
But I’ve almost done it again a couple of times :joy:

Hello - do you also have Vray running?


If I disable V-Ray, than we have an other situation and it works. Rhino doesn’t ask me to save the Untitled document, since nothing has changed. So, I think, the problem isn’t V-Ray. V-Ray is preparing every new opened file, also an empty file. If the user try to close it, than the Rhino code ask to keep the changes and … fails.

Not 100% sure, but likely. I did use vray in that project.

Yeah, something is changing the initial file that Rhino opens - Vray is one possibility, but the problem can be reproduced with a startup command for example. So it is not Vray to blame, it is a Rhino bug, I believe, but Vray can make it show up, it seems. I have also seen this on my system and Vray is not involved, but it only happens very rarely.



Hi @pascal,

I have seen something like this a few times and formed the impression that there is either a timing issue opening the file from the start screen or a process syncing issue - but no evidence, just gut feel.
I don’t have vray.


Happened to me as well, once. But being aware of this I know when to hit cancel. (Also Vray user)

happend to me also i thougt it was my fault fortunatly a backup file existed , indeed anoying and very dangerous, why asking everytime rhino starts for saving this etc etc fix it please

RH-60808 is fixed in the latest Service Release Candidate

1 Like