How to keep corner of subd model sharp?

Here’s what I have using “reflect”:

But now I want to stop using it but if I delete these faces I end up with this:

Marking all non-manifold edges as sharp does not help.

What can I do if I still want to keep the objects as subd?

(There’s still no “virual” mirror in Rhino you can easily turn on and off, is there?)

Use the subd vertex selection filter and select the vertex that is midway along the rounded corner and apply a crease to that.

Not sure but the problem @eobet might be that after deleting half of the geometry the remaining SubD does not have the same curvature. In contrast to T-Splines, SubD does not have any tangency points.

1 Like

@eobet can you please post this Rhino file?