How to disable objects rendering for objects (from blocks) that are on off layers?

I usually keep some 2D drawing, construction plans and other reference objects in layers that are off when I save a file.
When using this file as a block, there is no display problem with Neon or RhinoRender but with Brazil (and I remind that it also happens with Penguin), block objects with layer off are anyway displayed, as far as I am concerned.
How to do to disable objects rendering in Brazil for objects that are on off layers ?

with Neon:

with Brazil:

I use a lot of blocks in my animations (Bongo). Off layers were not a problem as I was using Neon. But I have switched to Brazil to get rendering synchronized with Bongo. As these blocks are used in several files and are not all mines, I hope that the only solution won’t be to duplicate the files of these blocks, delete off layers, replace previous blocks by new one (new file name) in the animation files.

Edit the block and uncheck ‘renderable’ in the Brazil section of object properties.

Thanks, that’s perfect for my project.

This Brazil/Penguin issue should be considered as a bug, right ?

Yes, I agree since Rhino Renderer does not behave this way. I filed these as