How to delete a material?

Is there a way to do this yet through the MaterialEditor?

I know this one’s on the list but I’m not sure when it might get added. The way it works now is that if a material is not applied to something and the file is saved, closed and reopened, the materials that weren’t assigned to anything should be gone.

Ok thanks Brian. I figured the MaterialEditor is still WIP.

There still appears to be no way to delete materials in the latest WIP.

Hmmm… this was fixed in Aug. '15 I just confirmed in the release build and also the latest WIP. Right click over a material swatch in the model materials section of the material editor to see the delete material option. Does that work for you?

I;m on the latest WIP and right click does nothing. 5C228W.

Same WIP build here. I’m so far unable to reproduce the absence of the right click menu over a material swatch in the model materials section of the editor. My thought was that it might be considered a context menu and that you might have that disabled in preferences… but it didn’t seem to matter. What mouse are you using and have you tried the track pad if you’re on a laptop? Two finger tap is the right click here.

I am using a notebook (mousepad). I normally us CTRL-CLICK but two finders does nothing either.

I am right clicking on the material (little shared circle).

Do you have the “Secondary Click” set to use two fingers tap or click in the OSX track pad settings?

You are correct enabling two fingers makes it work.

However, it does not recognize as secondary click (like the rest of Rhino does).