How to create barbs on a helix barbed wire?

I managed to create a helix chain in rhibo, but I need to add barbs along the helix to make it official looking… something along these lines:

I hate to say it but I’d use a bitmap in this case as well. Let’s see if we can figure out why you’re not getting transparency working. One more thing to check, shot in the dark, is whether in your Rendered display mode you’ve got ‘Advanced texture preview’ set.


Thanks man… Yes, I have that checked.

One more shot in the dark - just hit ‘restore defaults’ and see if anything changes…


Thing is, in rendered mode, I do see the chain, but render mode does a very poor job outlining the edges of anything circular like piping for a fence, so I stick to shaded or pen… but in these modes, the textures don’t show. I want to cry.

OK, I lost that detail, let’s ask the knowledgeable one, @jeff - do you have an idea? Peter can see transparency in materials ( that is using textures with alpha channels or transparent colors) in rendered display modes but cannot see the same objects with transparency if the viewport mode is a technical based one and the object display mode is Rendered. (Peter, did I say that right?) This works here.

Our example/test file is the file I’m attaching here - the wavy surface should appear as a ‘chainlink fence’ even in Pen mode for the viewport.

ChainLink_PG.3dm (272.8 KB)

Can it be that my AMD card actually has a case where it works better??


I just downloaded this file and opened it, and it works now… but when I copy that fence and paste it into a current project, it goes blank… I think it may have something to do with the scale… my project is imperial inches… Not sure what to make of it… It definitely works when I open it right after download.

I was just going to say that it seems to be working here as expected…

However, technical modes use their own specific pipeline, so getting things to look “rendered” in Technical modes is going to be somewhat of a stretch…and simply setting the object’s display mode is not going to be enough…it just doesn’t (and can’t) work that way… But…there is a more “proper” way to do this… you can set your technical mode’s “Shading Settings” to “Shade Objects” and set the “Color & Material usage” to “Rendering Material”… Then materials will show up in Technical modes…but IMO, at this point you’re really no longer technical mode…and it might be too much (more than what you want).

The bottom line here is that mixing pipelines and display modes via SetObjectDisplayMode isn’t really supported, and never has been due to technical reasons…and if you’re able to configure your scene to get your desired effect by doing this, then consider yourself lucky :slight_smile:

Thank you Jeff. I will give that a shot.