How to change the color of objects in Arctic view?

Hello a former colleague created this model and i am using Arctic view. I an unable to change the color of the blue boilers to the default white. How can I change the color of the blue boilers? Each boiler seems to consist of about 3 polysurfaces. I have already tried restoring the default Arctic view settings and no luck.


also sharing system info

Rhino 7 SR36 2023-12-12 (Rhino 7, 7.36.23346.16351, Git hash:master @ 11a364321297eb8cdb34405a3308d8911f58706d)
License type: Educational Lab License, build 2023-12-12
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 1660 SUPER (NVidia) Memory: 6GB, Driver date: 4-11-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 552.22
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port 0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-11-2024
Driver Version: 31.0.15.5222
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Bongo 2.0 (64-bit)\Rhino6\Bongo.20.rhp “Bongo 2.0”
C:\Program Files\Bongo 2.0 (64-bit)\BongoUI.20.v60.rhp “BongoUI20v60”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.36.23346.16351
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.36.23346.16351
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.36.23346.16351
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.36.23346.16351
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.36.23346.16351
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi @Orlando2 ,

It’s possible that those objects have their own display mode “per object”

You can check in the Object Properties of the boilers and ensure that the Display Mode Setting is “By View” and that Display Color is “By Layer” or whatever the other objects are set to.

Hope that helps!

1 Like

They could be set with SetObjectDisplayMode to use the Rendering material. If they are block instances, edit the block to change the display setting.

1 Like

hi @michaelvollrath I dont seem to have Display Mode as an option

@Orlando2 Are they blocks? If so to @BrianJ point you may need to change inside the block itself.

@BrianJ does R7 not have DisplayMode as an option?

Sorry Orlando, I started using Rhino in version 8 so I’m not familiar with what is omitted in previous versions.

v7 didn’t have that property visible in the Properties panel.

@Orlando2 use the command SetObjectDisplaymode to switch them to use the viewport’s mode. That’s my best guess at the issue without seeing those objects specifically.

1 Like

hi @BrianJ i tried that but nothing happens. It turns out each boiler has one block, which is the black cylinder and the grey disk behind it. But the boilers themselves are not blocks, they are made up of multiple polysurfaces.

will you post the boiler and a few pipes in a new file so we can take a peek at the settings that are embedded in it?

hi @theoutside here is a file with a boiler and some piping. I had to trim out a lot of the components so the file is small enough to upload here.
2024_0514_boiler model.3dm (13.1 MB)

see below-

  1. set view to artic mode
  2. set objects to boiler layer that you want to display blue
  3. right click layer and “select objects”
  4. use -setobjectdisplaymode command to set display mode of blue parts to “shaded”
  5. adjust shaded mode settings and material to achieve the correct look. (turn off edges)

Thanks for uploading the file. This issue doesn’t occur in Rhino 8’s Arctic mode but I see what you’re reporting in Rhino 7. Since the material for those objects is white already, the quickest fix is to select those objects and use SetObjectDisplayMode to use Rendered mode for them despite the display mode. I haven’t nailed down what is special about this collection of objects to suggest another fix in v7.

Thank you @BrianJ this worked !

1 Like