How to change avatar image?

i exchanged it, on the login page it shows the new avatar instantaneously, but here not so i deleted it logged out and in several times deleted all caches but still its hanging in there.

1 Like

If you look now in another browser, is it still the old one?

yup in any browser and also ios, one tough BUGger i must say
@brian any idea?

In Chrome also…:pensive:

@aj1 it looks like @RichardZ did all the right things, but still has the wrong Avatar at discourse.mcneel.com - can you please see if you can figure out what’s going wrong?

@RichardZ

Can you confirm you did the following:

  1. Go to accounts.rhino3d.com -> Personal Info.
  2. Change your avatar.
  3. Click Save at the bottom right.
  4. Go to discourse.mcneel.com
  5. Click on your (old) avatar at the top right and Log out
  6. Go to discourse.mcneel.com
  7. Log in.

yes thats what i did, i also danced a walzer with my laptop and sent a space invader through my modem.
i was sure it will not help but i could not resist :smile:

maybe somebody has to knock on meta.discours’s door?

tumblr_o4vo5gS3UW1u3xafro1_500

Hehe, upon further research it looks like your avatar is not being saved at accounts.rhino3d.com. What method are you using on the Personal Info section for your avatar? And at the risk of dumbing things down too much, are you sure you are clicking save?

hmMMmm i haven´t ingested any fancy stuff for a long time, but i am getting old thats true :smiley: still i am pretty sure i managed to hit the save button, also because i did this procedure twice and have actually deleted the avatar in the end. i can try again but it kinda feels like scratching on my vinyls try again -> tr-tr-try again

Give this recipe another go:

Go to accounts.rhino3d.com -> Personal Info.
Change your avatar.
Click Save at the bottom right.
Go to discourse.mcneel.com
Click on your (old) avatar at the top right and Log out
Go to discourse.mcneel.com
Log in.

It’s important to follow the steps faithfully to come out with a good result.

to shorten this logically i might repeat that its happening on the accounts page, i have successfully changed and also deleted the avatar there. i have repeatedly logged in and out on the accounts page and also on the discourse page.

resuming, i have no avatar on the accounts page since yesterday, here still the old avatar which actually got replaced and finally deleted in a second attempt.

to me it seems the account page is not communicating with discourse.

What happens is the following:

  • Every time you login to discourse.mcneel.com, it asks Rhino Accounts for your current avatar.
  • If you have no avatar in Rhino Accounts, Discourse uses the last avatar it cached from Rhino Accounts the last time you logged in.

well that would skip out the option to neutralise ones avatar… but anyhow i have done this now once more and added a new avatar. i have a new avatar on rhino accounts kept logged in there, logged out and in here repeated the same while being logged out on the rhino account, still the same old story. worse than dogspoo on a shoe.

@RichardZ just to make sure did you log out of discourse?

Go to discourse.mcneel.com
Click on your (old) avatar at the top right and Log out

yes i did, i even got kicked out now saying “you where logged out” while writing on some text here. never happened before. i assume that had nothing to do with you?

As another data point, here is what I did:

  • logged out of discourse
  • logged into accounts
  • verified that my newly chosen avatar is still in fact there, which it is
  • logged out of accounts
  • logged into discourse
  • I see the old avatar

I am using the latest Firefox on Windows 7, and my account name and password are saved by the password manager.

I performed these operations a set of times - the avatar is displayed old.:disappointed:

It looks like there are indeed some issues with avatars getting displayed correctly in the forums. I am waiting to hear back from the Discourse folks to see if they have any insight in the situation. We’ll get those shiny avatars showing up on the forum soon!

1 Like

I’m having the same problem. I’m a new user. I created my account at accounts.rhino3d.com today. I saved my avatar there and it appeared correctly there. Then I logged on to discourse for the first time, and my avatar didn’t show up. I’ve logged in and out multiple times, but still no avatar. FWIW, when I log on to discourse, I briefly get a page that says “Just one second…” that does display my avatar correctly in the upper right hand corner, but the avatar disappears when the forum list is displayed.

Yes it looks like you’re a victim as well. I’m still on top of this waiting to hear back from the Discourse folks to see what they or I can do to fix it.