How to build those fillets?

rolling ball brings some overloaded with CPs surfaces, other methods fails

extend the lower fillets until you reach the edge on your bigger fillet and blend the lower ones. Match the blend. If you don’t like what you see you can also use two blendcurves, modifying the size of the lower blend curve.

1 Like

thank you, blend works, but when I try to match with this big vertical fillet and bottom surface I see this.

One thing to check is that your render mesh settings in the options dialog are set to smooth & slower. Not sure this is your issue or not.

Hi Andre - it is much easier to help if you post a file with the surfaces you are asking about.


Thank you, here is a new file andrii_fillet.3dm (344.3 KB)

Is it possible to pullback the curve on to surface with curvature continuity?

The apparent discontinuities in the zebra stripes are due to too coarse a display mesh. In the Zebra command pop-up panel click on “Adjust Mesh” then “Simple Controls” if the detailed controls are shown. Move the slider all the way to the right towards “More Polygons” and the zebra stripes should be continuous.

Hi Andre - one thing you can do is MakeUniform on the side fillets and then match again to the larger surfaces. Then if you can align the edge points of the fillets so as to line up without trimming:


Then MatchSrf all around, I think you can get good results.

andrii_fillet (1)_PG.3dm (84.0 KB)



Thank you Pascal for this great explanation! It works!
I have the further question, how would you match with this bottom surface?
It would be by default if this surface would be flat, but it curved.
Here I cut this small piece and blended, should be better way, right? andrii_fillet_match.3dm (5.0 MB)

Hi Andre - if I left out the bottom match, use matchSrf there for tangency. It is already very nearly G2 and just sucking it over to meet the edge at a tangent may be enough - that way the third row of points is not moved. In more extreme cases (i.e where the ‘floor’ surface has a lot of curvature and the six control points are not enough for a good match) you can InsertKnot, vertically, on the corner piece with the Automatic option and then MatchSrf.



1 Like

Thank you! Unfortenatually even with knot insertion there are small imperfections

I dunno - it looks OK here - I did not add any knots this time to the corner piece but I did to the side fillets as they were not getting quite close enough to the walls, but that is different…

andrii_fillet (1)_PG_Again.3dm (171.8 KB)

Also, I’d be inclined, just from a design point of view, to make those fillets a little more ‘accelerated’ than round, in section:



@Andre_Pokhodzei What is mesh setting is used by Zebra? If the Zebra display mesh is too coarse then there will appear to be imperfections which do not exist in the NURBS math data.

Congrats, all edges have g1. I accept G1 if deviation is under 0o05 angle tolerance.
You shouldn’t believe Zebra so much. As the others said, its up to the tessellation.

1 Like

In the model you posted the surfaces are not even G0 (they won’t join)

You could be done with this in a couple of minutes if you made all the fillets as rolling ball fillets using the filletSrf command. Fillets crossing over other fillets is quick and easy if you make them all rolling ball fillets.
Not_G2.3dm (286.0 KB)

That’ wouldn’t happen if you make the vertical fillets as
G1 rolling ball fillets.

Thank you so much! remodeling it from the start and after MakeUniform can`t match the fillets back to flat surfaces

andriifilletsnew.3dm (4.0 MB)

Hi Andre -
@Andre_Pokhodzei - use the ChainEdges option in selecting the edges to match - the target object has two surfaces. The other option is to split (and ShrinkTrimmedSrf the fillet at the edge between the two target faces.


1 Like

Thank you! Now fillet corner is complex, what to do?

Hi Andre you can live with it but the structure should match without the complexity but, it looks like you have not lined up the rows of control points as I outlined here

If you do that and the surfaces are untrimmed you should be able to get a clean match with no extra points. Remember to pay attention to the ‘Match by closest point’ (don’t use this if the edges are untrimmed and the structures match) and ‘Match target isocurve direction ’ ( use this in the same cases if possible - that is one reason to make the surfaces’ point rown have the same directions to begin with.)


Thank you, I`ve allready made those fillets uniform, matched to large surfaces and now try to make Blend, result is the same with trimmed or untrimmed surfaces. Interesing that neighbor corner fillet that shares one of this fillet surfaces is correct.andriifilletsnew.3dm (13.4 MB)