How to adjust this silly LOFT component?

Hi All, I am making the voronoi structures, but the error always come from this LOFT component, how should I adjust it, and make the whole voronoi structures be lofted to be the surfaces?

Thanks in advance! The screenshots you could find below:

<a class=“attachment”

ps. I have already tried to change the Number Sliders of “Count” and “Seed” in 3D Population Component, but the LOFT component seems very instable, some time it works and some time it doesn’t… Why is that?

check the loft in this file - it’s using the same method without errors (53.0 KB)

1 Like

Hi Corellaman,
thanks for your reply, it indeed works in your hemisphere, but when I draw a similar shape and set the brep, the same error still shows on the LOFT component, I have uploaded the GH file in attachment, if you could check, that would be very grateful, thanks again :slight_smile: (133.2 KB)

You can use Ruled Surface component instead: (133.3 KB)

1 Like

Great! Thanks Mahdiyar, problem solved!

Charles TT,

Couldn’t return to the post earlier, plus @Mahdiyar suggested a perfect solution.

Your problem however is (or was) that you had invalid curves - once cleaned it’s all good:


Thanks a lot, Corellaman, I will try it as well.
yes, the solution with more options will be definitely better!

surely! you can always rebuild the inside curves different ways (as long as they’re closed) to get some other wacky results:

hahahaha! rebuild is really cool, I will try more:rofl: