How do I find the GUID of the plugin object?

I’m trying to run some old scripts on a new machine that’s running Rhino 5 and the V-Ray for Rhino plugin (that comes with Matrix 7.5). I get the ‘Object Required’ error on the following line in my script:

 Set vRay = Rhino.GetPluginObject("{E8CFE179-B60C-411A-8416-62A893334519}")

I feel like this might have something to do with the wrong GUID. How do I determine the GUID of the V-Ray plugin or any scriptable plugin in general?

I guess here:

HTH
-Willem

1 Like

Thanks, @Willem! That’s what I was looking for… although the GUID doesn’t seem to be the problem and the error still remains. I don’t know why.

Rhino.GetPluginObject(“Grasshopper”) doesn’t work?

@krsnadas, can you post relevant portions of your script? I can only reproduce this error if VRay plugin is not loaded, i mean when i enable load protection in the Plugins dialog and then run your code.

c.

@DavidRutten , yes calling by name does seem to work. But it’s just that @matt_newberg recommends calling plugins by GUID.

@clement thanks, I tried removing “Set” from the above piece of code and weirdly it worked. But, now I’m stuck with the software-related issue: my V-Ray plugin (which comes with Matrix 7.5) is not being detected by my 64-bit Rhino 5. I’m working this out with Gemvision support.

@krsnadas, if VRay is loaded and your current Render plugin, it should be accessable using:

Dim vRay
Set vRay = Rhino.GetPluginObject("E8CFE179-B60C-411A-8416-62A893334519")

I am shure that the Set statement is required in RhinoScript (vb). This does not apply to python. If you think the problem comes from Rhinoscript or the id makes a problem, you can try this:

  1. enable Rhino renderer under Render > Current Renderer > Rhino Render
  2. Enter the command _SetCurrentRenderPlugin
  3. Paste the plugin id into the command line

In my case the commandline reports Current render plug-in set to "V-Ray for Rhino

c.

In my case, I get “Unable to set current render plugin to plugin with ID: E8CFE179-B60C-411A-8416-62A893334519”.

Yes correct, we recommend finding plugins by GUID so you can run the same script in V-Ray For Matrix and V-Ray For Rhino. The plugins share the same GUID but have different plugin names.

What happens if you set VRay current through the menu as described in step 1 above ?
Is this Rhino 4 or 5 ?

c.

@clement That menu showed only the Rhino default renderer in my 64 bit window. The 32 bit version showed VRay, but when I would set that, Rhino would crash. As I’ve been made aware of at this point by tech support, it turns out the Matrix I was using is a 32-bit version which I’d need to update to 64 bit from here: https://s3.amazonaws.com/gvcommon/renMatrix7.5_Build4087_International64bit.exe?AWSAccessKeyId=AKIAI6ZVRFF3742VWXLQ&Expires=1441977375&Signature=K1MHbFwABVBfkaD8Z3STkuda27s%3D

@krsnadas, OK this should be the errorsource, Once properly installed VRay x64 is listed in the menu under Render > Current Renderer.

c.

1 Like