How do I add units to my measurments so they read 67.05mm instead of just 67.05?

So my problem is this, I want to show the units but I can’t figure out how to add the units of measurement next to the dimensions once created.

So for example, it will read 67.05 instead of 67.05mm.

How do I show the units?

Don’t double-post. Ask your question once, be patient for answers.

Sorry, I only realised that I could create my own thread instead of clogging up another one.

explore the options window.

I’ve had a look but I cant find anything that fixes my issue. I can only convert the units from mm to feet but I cant show them.

In the properties window of the dimension, under “Length units”, and “Suffix”
Also, in Options, you can also add it to the Annotation Style to make it permanent…


Someone get this man a beer. Thankyou very much!