How can i remove these join lines?

Hi

Can someone advise how to get rid of these join lines please? I run into this problem alot and tend to view things in arctic as they dont show up but Arctic with outlines is much easier to read so i need to get rid of these please.
Is it bad geometry or is there a quick fix that i can turn off in display mode? I have attached the model too.
Thanks
GET RID OF THESE LINES.pdf (1.1 MB)

CANOPY.3dm (1.3 MB)

You have a bunch of intersecting volumes, there is no way to turn off the edges on those. The solution is to make the object without overlapping parts - using various trim/join/Boolean operations.