How can I make Query-Model-Objects stop updating on visibility change?


I have been experimenting with the new RH8 Query Model Objects in GH. For the most part I don’t really love their behavior and prefer to stick with the older Pipeline components. However the built-in support for Blocks is very nice and I’m very keen to use that part.

However: I am running into trouble using the Query Model Objects now. I would really like to get them to STOP firing on every change in the Rhino-doc’s layer-visibility state? I don’t see any reason why they should update based on layer-visibility, and in fact this makes several use-cases of mine recursive and breaks my model.

In particular: I use an automatic ‘print’ tool which is run from inside Grasshopper. During batch prints, it sets my Rhino scene’s layer visibilities and prints large document sets (many hundred-page PDFs, one page at a time). However since every time it runs it sets the Rhino layer’s visibilities, the Query Model Object component re-fires, and so it then triggers the batch-print to start all over again.

Also, no, I really do not want to use Data-dams as I feel this defeats the whole purpose of the query objects. I do want the query-model-object to always update if the entities on the target layer change, but I do not ever want it to update if I’m just changing my layer visibilities or executing a hide/show operation. There must be a way to turn this behavior ‘off’, no?

I would note that the older ‘Pipelines’ do not behave this way, and do not fire on layer-vis change.


Hi Ed,

There is a feature request in for more control over Query Model Objects, there is also discussion of a ‘dumbed down’ version.

1 Like

Hi @Japhy

That is great to hear - this sounds like a good approach and I very much hope that these options can make it in at some point. thanks!