How can I increase speed for the large mesh file?

I use the bbox, there is no improve for the large mesh object, it only for nurbs object, please help, thank you!

I using win 7, i7 4930k, k4000 or p4000. P4000 is also can’t increase speed for large mesh

Hello - you might want to turn off drawing mesh wires in the display mode.

-Pascal

I see you are using .norm file format