Horizon won't lock with ANY mouse in RH7

I had originally posted this about the CadMouse Pro Wireless, but I went back to trying my old mouse (Logitech G700s) and that’s having the same problem. Here’s the original text:

In RH7, (EDIT) every mouse I try loses Horizon when using RMB to rotate.

In RH8, this is not an issue.

Tried it in Safe Mode. No luck.

Any thoughts greatly appreciated.


Rhino 7 SR18 2022-5-4 (Rhino 7, 7.18.22124.03001, Git hash:master @ b2a1120bcb32e1f6da66a421cd7162a18a9f0cd9)
License type: Commercial, build 2022-05-04
License details: Cloud Zoo

Windows 10.0.19044 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3060 (NVidia) Memory: 12GB, Driver date: 4-20-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 512.59

Accelerated graphics device with 4 adapter port(s)

  • Windows Main Display attached to adapter port #0

Secondary graphics devices.
NVIDIA GeForce RTX 2070 (NVidia) Memory: 8GB, Driver date: 4-20-2022 (M-D-Y).

Accelerated graphics device with 4 adapter port(s)

  • Secondary monitor attached to adapter port #0
    Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 1-22-2020 (M-D-Y).

Integrated graphics device with 3 adapter port(s)

  • There are no monitors attached to this device!

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-20-2022
Driver Version: 30.0.15.1259
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 12 GB

Rhino plugins that do not ship with Rhino
C:\Users\alanf\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\IntelDenoiser\0.6.4\IntelDenoiser.Windows.rhp “IntelDenoiser.Windows” 0.6.4.0
C:\Users\alanf\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SubstanceImporter\2.0.1\Substance.Win.rhp “SubstanceImporter” 2.0.1.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Users\alanf\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SectionTools\2021.4.30.511\SectionTools.rhp “SectionTools”

Isn’t this a setting?

See the “Rotate” section, you have “rotate relative to view”, maybe?
If so, just set it “Rotate around world axes”.

:sweat_smile: :Thank you, @maje90 …I’m so very embarrassed :grinning:

Don’t be.
I also use rhino for 15+ years, and still I find new stuff and options…

1 Like