Hops not working in huge amount with the version above 0.10.1

Sorry for the similar content and my poor English.
As it seems that I could not modify the title or delete my post, I repost to correct some confusing descriptions from the last post.
First of all, could you help to close my last topic?


I have found the error of computing in huge amount when I try to use every updated version of Hops since 0.10.1.

The main definition I used in Hops is to convert the formated string to the plane, please see the screenshot below (please kindly find the attachment at the end):

and I found the below situations:

  1. The function will perfectly work when the amount is not so huge, maybe is below 2,000.
  2. When I used it in the amount of 26,508 in the example, and the version in 0.10.1, this eventually worked the second time.
    Although the first time ran red, I could re-enable to get my expected results. Please kindly find the error
    for the first time run if possible.
  3. Same amount of 26,508, but the version is above 0.10.1 including the latest 0.15.0, which I have tried all the updated versions. The Hops component becomes not working and keeps the error in red.
    Always like below:
    And I checked something maybe useful was the cache items only have only a half in the preference settings.

Please help to address the issue, the below attachment may help to build this error.
There are two files in the zip, please keep them in the same folder, and open the “check with Hops”.
Thanks in advance!

@AndyPayne could you please take a look and give help on this? Many thanks

Check With Hops.7z (1.6 MB)

Hi -

Using named groups as the output of the Hops component is the old way of doing this. The Context Bake component was introduced to handle this, and this seems to be working fine here:



1 Like

I am very excited to hear the good news for the only reason I take the outdated way.
I have tested immediately and got my success. Thank you so so much!!
I should read again the guide and I can take so many new tries on it, thanks again!