Hops 0.9.0 all outputs are disconnecting themselves

I am excited that the Hops inputs and outputs are now respecting their Y positions inside the definitions!

But I’m finding that all of my outputs are disconnecting themselves each time anything in the Hops definition is changed, but even worse they are not surviving a save/close/open cycle of the host grasshopper file.

Each time I try to reconnect the outputs they only work until I close the file. Upon reopening they look like this:

It would be great if the output connections could also stay connected when adding or removing outputs.

Is anyone else using Hops 0.9.0 and not having all of their outputs broken after re-opening their Grasshopper files?

I’m just as glad to find out if my problem is operator error as opposed to a bug in Hops. Currently Hops 0.9.0 seems unusable for me if I have to reconnect all outputs every time I open a file.

Testing again on a much simpler Hops component still has the same result: all connected outputs disappear after closing and opening the file:

Does this happen on every saved file with a Hops component in it? Do you have a simple test file that consistently shows this problem? I will try to test this as soon as possible. If it is a bug then we’ll try to fix it and issue an update as quickly as we can. For now, you may want to consider downgrading to 0.8.0 (via the package manager) to see if that fixes this issue until we get this fixed.


Yes the bug is consistent for all Hops components which I’ve tried.

Here is an extremely simple example:

Hops Outputs disconnecting problem.gh (1.5 KB)
Hops Outputs simple example.gh (1.1 KB)

You’ll have to point the Hops component inside the first file towards the second and reconnect the outputs.

Closing then reopening breaks the output connections every time for me.

Is anyone else not seeing this issue with Hops 0.9.0?

I would like to confirm the bug, happens to me all the time too. Have to replug even when working on the hops def in an another rhino instance. When back to the original def with the hops components, have to replug everything back in. It’s frustrating a bit.

1 Like

Andy was able to repeat this and is working on a fix. We should have a new release very soon

1 Like

@LeoPedersen @zvombie I’ve just released a new build of Hops (0.10.1) to the package manager. I’m hopeful that this build will fix the issue you have reported regarding output parameters failing to reestablish their connections to recipient parameters upon reopen. Please pull down the latest build via the package manager and let us know if this resolves this issue.

1 Like

Thanks very much Andy!

Tested on small & large Hops definitions just now and the connections are preserved after closing & re-opening.