History directive "#" is ignored in "Python Script"

In command line, “#” is "History ON "
> #Pipe
it works with history

but in Python script
> cmd = “#Pipe _Thick=_No _Cap=_None 1.0 1.0 _Enter”
> rs.Command(cmd, True)

it works but without history.

I hope Python script’s command work as same as command line’s command.

I am not sure if this is supported; @dale might know more. But you might use

rs.Command("_History _Record=Yes _Enter", True)

to enable history recording, before your command.

@pascal, any thoughts here?

Indeed it seems not to work from within RhinoScript but it does work as a normal macro in Rhino as far as I can see.


I found that pasting the macro string in the command line does not work either.


@Katsu, this seems to workaround the # problem using python.