Highlight color glitch

Please notice the captures below:

On occasion, Rhino goes wild and reverts to black. If I close reopen the file, proper color is displayed.
I guess not many people change the default color options in Rhino and this has gone under the radar.


Hello - are you running any plug-ins with Rhino?


Hi Pascal,

Yes, I run some plugins from Logis SLR.
Should I disable them and see if I can replicate behavior?

Hi Yianni - that is what I would try first - disable third party plug-ins, (Options > Plug-ins page) and see - if it works correctly, load the plug-ins one at a time and see if and when the problem turns up again…


Will do and report back, thank you !

Hi @pascal, I can now confirm that after disabling all 3rd party plugins the glitch resurfaced.

It occurred after I used picture command.

Can you describe specific steps which make this issue appear?
Also, if you need anything that is not factory-default, please describe in as much detail as possible what needs to be changed for this to happen.

Hi Wim,
Thanks for looking into this.
This one is going to be tricky because I have not yet found a pattern to replicate, the only thing that might help is that it usually happens when I do a relative memory intense task, such as copy/paste from another Rhino instance.
I will keep looking out for clues but please advise if I can offer more intel to track this.
Also, am I the only one who ever had that issue?

I don’t recall anybody else running into this specific issue.
Please run the Rhino SystemInfo command and paste the results - that way, we might be able to eliminate anything “obvious”.

Sure, here are the results:

You may eliminate Thea plugin as a suspect, it was just installed recently.

Rhino 6 SR9 2018-9-28 (Rhino 6, 6.9.18271.20591, Git hash:master @ 4cf7435f08f51c972347c8558d28355cfc0471ca)
Licence type: Commercial, build 2018-09-28
License details: Cloud Zoo. In use by: Yianni Andrikopoulos ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: VJ-PC9

GeForce GTX 660 Ti/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 416.34)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-10-2018
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.9.18271.20591
C:\Users\Yianni\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\Thea For Rhino (0ab51401-0ca2-45e3-94e0-46d77b129353)\2018.3.18.0\Thea_V2\TheaForRhino.rhp “Thea For Rhino”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.9.18271.20591
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.9.18271.20591
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.9.18271.20591
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi Yianni - does this happen in any display mode or just some? Does it happen with any type of object?


It happens on all display mode and with with all entities (lines/surfs/meshes).

Just installed SR10 and the glitch changed behavior.
Please see video:

@pascal are you able to replicate the behavior change?
Would be great if it could be addressed, it’s quite annoying.

Hi Yianni - so far as I know no one else sees this… Nothing in your system info stands out, to me… does this happen with any file, even a new one with just a box or something?


Hi Pascal,

It does not happen when I start a new file but it might or might not happen during modeling.
Schrödinger’s Rhino :crazy_face: ! Restarting of Rhino fixes it.

Since this is an odd situation and others dont seem to experience it but I have it in both of my workstations I will start by creating a new template to use. If that does not fix it I will have to reinstall Rhino.

Can you specify which registry keys to remove for a complete uninstall?