Helps with springs component from kangaroo

I’m getting an error that the springs can not start with a zero value and I tried to cull that item and I can’t get it to work properly. I’ve tried looking around the internet and found similar problems. I don’t understand why the cull isn’t working though. I’m new to gh btw. Only used it for around 2 months so far.

my model for the ferry terminal.3dm (885.3 KB)
hexagonal (15.7 KB)

update: I was able to find out that the error in the cull parameter was because I typed enter in the text connected to it. However I still get the error in the springs

I also tried attaching the cull to all the definitions that attached to the springs. you can see the panels.

Why don’t you eliminate 0 length lines which is the cause of your error message?

hexagonal (10.3 KB)

1 Like

Thanks alot for teaching me something new. I didn’t know how to ask this. This worked for me :slight_smile:

Hey Kim,

I re-opened the file to work on the design and it’s giving me an error now that data conversion from curve to line failed. Why would this happen if the file was working fine before ? Or maybe I’m missing something. Don’t mean to ask you again but I thought you’d be the best to ask. I’ll post it in the forum as well. my model for the ferry terminal.3dm (1.1 MB)
hexagonal (21.2 KB)

hexagonal (19.5 KB)

1 Like