Help with Rhino install on new laptop


#1

I’m traveling outside the US on business and need to load Rhino 4 on a new laptop. I have my Rhino 4 license key on hand but I don’t have an old Rhino 1,2 or 3 CD with me to complete the installation process. I downloaded Rhino 4 from here: http://www.rhino3d.com/download/rhino/4.0/release

Is there any way to load Rhino 4 without a previous build on my new laptop? Thanks in advance.


#2

Yes. But if your Rhino 4 is an upgrade license, you will need a CD key for a version 3 or earlier of Rhino, you will be asked for it during installation.

https://wiki.mcneel.com/rhino/installationadvice (towards the bottom of the page)

This is for Rhino 5, but same applies for Rhino 4:

If it still doesn’t work, contact sales@mcneel.com directly.

HTH, --Mitch


#3

Thanks for the timely reply. My Rhino 4 was an upgrade license. If I call home for the Rhino 3 key will I still need a CD? The installer prompts for a CD drive letter…


#4

Been a long time since i installed a V4, but I seem to remember you don’t need the CD. The installer should prompt for a key or just to insert the disc (if you have one), but I don’t recall it asking for a drive letter

@Rodri - if you’re there, can you clairfy?

–Mitch


#5

The installer keeps prompting for a drive letter. No option to input a Key. Frustrating.


(Rodrigo Bárcena) #6

@Helvetosaur @L_J

A Rhino 4 upgrade needs either a physical disk, or an existing previous installation.

Only Rhino 5 installers will let you skip the above and just enter the licence key.

@L_J
A possible solution for you would be then to install Rhino 3 (I’m assuming you have the licence key, ask our sales desk if you lost it). I’m sending you a download link for Rhino 3 on a private message.


#7

So you get to this screen and you enter your V4 key, and then it asks you for a drive letter?

In any case the installer you downloaded doesn’t work at all here on my Win 8.1, I had to navigate to the temp folder where the program extracted to, find the installer .msi and run that…

–Mitch


#8

Ahh, I thought that was already possible in V4, sorry… --Mitch


#9

Many thanks again for the support. There is something wrong with that link…site can’t be reached…


(Rodrigo Bárcena) #10

I’m trying another one… ; )


#11

Thanks


#12

It’s mind numbingly slow. I’m trying to VPN to that link. Getting 10k speeds at best…looks like a couple of days download from this banana republic…


#13

The download just quits around 2mb.


(Rodrigo Bárcena) #14

that’s the second one I sent you, right?
not sure if I can me of much help… : /


#15

that’s the second one…can’t seem to get beyond 2mb on the download. It’s terribly slow too…


#16

25k now. Really flying…1h35m download…


(Rodrigo Bárcena) #17

it’s a S3 server (amazon), I tried here and the download is fast and stable … unfortunately I don’t know why that wouldn’t work for you.
send me your e-mail address in a pvt message and I’ll try an alternative method for you.