Help with Intersecting Surfaces

not-intersecting.3dm (66.3 KB)

I want to split the smaller surface by the larger one. I’ve even SetPt all the bottom most control points, completely untrimmed as well. Usually in this kind of case, I find a fillet/arc has gone slightly above a plane, creating a small gap which stops the intersection. I can’t see what is wrong here though, or anymore tools I could try.

I even tried extracting the control polygons and the wireframes, and everything intersected to a point. RebuildEdges, ChangeDegree - no luck.

SetPt reveals ‘unable to transform 1 object’.

I think it’s because the smaller object is too close to the edge(they share a point on the edge).
I just downloaded, ungrouped, moved the smaller surface inward and it split successfully.

Hi Jonathan - if you set the file tolerance to .0001 you can get a clean intersection. I’d think .001 would work at this scale but it does not - .01 is getting too large for small objects like this.


1 Like

It’s as you say… ; ) That works with moving anything

other work around without moving cp’s could be using the _Intersect command and then, _ExtendCrvOnSrf to split the surface with it.

Sadly I couldn’t even get a normal Intersect to work.

Oddly, a rebuild to 4,4 and 7,4 (smaller surface) fixed it, and the deviation was within tolerance. But perhaps that is going to just cause more problems down the line…

Is it unwise to change file tolerance for one command? Maybe I need to consider a big shift over of everything to .001, but will my work not just becoming so much more isocurve heavy? Also FYI this is from the same file as the iGES topic from the other day, so the signs point heavily to a change of some kind…

Any thoughts for the ‘Unable to Transform 1 Object’ message?