Help with alias weirdness


#1

Hi,

I can’t figure out what I’ve done wrong here…

I want o make an alias that will group a few curves and then hide them. Seems pretty simple.

Here is what I add:

grhd (Alias name)    ! _Group _Hide

However, it doesn’t work. The _Group works but the _Hide doesn’t.

It seems to try to execute the previous command line command or something, providing ‘_Hide’ as an option. (As per the inserted image below…)

Here is the command history…

I’ve tried a bunch of different things in the alias but I can’t make sense of it.

thanks
Peter


#2

Hi,

Try this: ! _Group _Pause _SelLast _Hide

You need the _Pause to allow you to select the objects if they aren’t already preselected; the _Sellast is needed to re-select them after _Group because they get unselected (if they were not preselected).

! _Group _Hide does work if the objects are preselected, but ! _Group _Pause _SelLast _Hide works in both cases.

HTH, --Mitch


#3

Hi Mitch,

I’m starting think it doesn’t have anything to do with the actual alias…

I tried your suggestion, but I had a similar problem, as follows:

As you can see, it just tried to repeat the previous rectangle commands… I can’t figure out why.

cheers
Peter


#4

Odd… If you make a new alias (different one) does it do the same thing?

I just realized this is in the Mac category - since the alias stuff was recently revamped, maybe this is the problem? Check out this thread


#5

Hmmm,

seems that way. I tried a couple and same each time.
No problem with existing aliases.
is this just me?

cheers
Peter

PS, here is my machine info…

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2014-06-10 (515)
OS X version: Version 10.9.3 (Build 13D65)

Plug-ins
/Library/Frameworks/3DconnexionClient.framework/Versions/A/3DconnexionClient

Hardware information

Computer hardware
Hardware model: MacBookPro10,1
Processor: Intel Core i7-3720QM CPU @ 2.60GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GT 650M 1024 MB
Memory: 1024 MB
Screen size: 1600 x 1200, 1680 x 1050
Displays: SyncMaster, Color LCD

Third party kernel extensions
com.attotech.driver.ATTOiSCSI (3.4.1b1)
com.parallels.virtualsound (1.0.27 27)
com.nvidia.CUDA (1.1.0)
com.Logitech.Control Center.HID Driver (3.3.0)
com.3dconnexion.driver (1.7.1)

USB devices
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller
Logitech: USB Receiver
Mitsumi Electric: Apple Extended USB Keyboard
Tablet: XD-0608-U

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-8.26.21 310.40.35f08
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: None
Mip map filtering: None
Anisotropic filtering: Low


#6

As I edited my post above, the alias stuff on Mac has changed, see this thread