Help! rhinoscript error

hello,

since the rhino update, of this morning,
i ve got an error message when i launch a rhinosrcipt:
image

! _-Runscript (
Option Explicit
'Script written by <insert name>
'Script copyrighted by <insert company name>
'Script version mercredi 3 décembre 2014 15:01:55
...

Rhino 7 SR6 2021-5-7 (Rhino 7, 7.6.21127.19001, Git hash:master @ aec74c050f3ca28ab3cfd6882e9453a52366a9b7)
License type: Commerciale, version 2021-05-07
License details: Cloud Zoo

Windows 10.0.19041 SR0.0 or greater (Physical RAM: 24Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA Quadro K4000 (NVidia) Memory: 3GB, Driver date: 12-6-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 441.66
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-6-2019
Driver Version: 26.21.14.4166
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 3 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\ADA 3D\Mesh2Surface for Rhino 6\m2s_for_Rhino.rhp “MESH2SURFACE”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.6.21127.19001
C:\Program Files\Rhino 7\Plug-ins\RhinoScriptEditor.rhp “RhinoScript Editor” 7.6.21127.19001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.6.21127.19001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.6.21127.19001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.6.21127.19001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.6.21127.19001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.6.21127.19001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2019.7.29.584\SectionTools.rhp “SectionTools”

one idea???

In Options>Plug-ins (Modules), check to see if the Rhinoscript plug-in is enabled?

image

(it is in the list in your SystemInfo, but I don’t know if that means it is enabled)

yes it is!!

Hmm, OK, and this happens with any Rhinoscript?

You could perhaps try a Repair installation - go to Windows control panel, Programs, Uninstall, find Rhino 7 in the list, right click on it and choose “Change” then on the splash screen, choose “Repair”

image

image

i’m on internet, but in the " fichier journal d’installation" it talk about DOWNLOAD CACHE FAILURE

do i have to re install all rhino 7?

This looks like it is a problem related to this -

and this -

https://discourse.mcneel.com/t/installation-problems/1238

Looks like the temporary solution is to download and install DotNet 4.8 first as per the directions in the last post in the first link above.

thank you, but no change, i do the solution in the discuss of the first link.
your second link doesn’t run…

i don’t know, what can i do… every rhinoscript run when i launch them form the editor, but, the command
! _-Runscript (
in the button doesn’t run!

all my rhinoscript in button, are write like this:

! _-Runscript (
[Script]

it was running… but now no, so i just add a ‘)’ at the end so:

! _-Runscript (
[Script]
)

and now it’s ok!!!

excuse me for time, it’s ok now i think!

Ah, I was under the impression that the last ‘)’ has always been required and that it would not work without that. So I assumed you had one in your button already.