Help Needed with Loft Command


I have a problem with the Loft Command. I want to loft the upper row of elements with the ones below (Image 1). the elements below have a different scale so simply extruding them does not work.

when using the loft command it’s only possible to do every element one by one.

maybe connecting more than one curve with the loft command like shown in image 3 (source from internet) would solve the problem but for some reason that’s not possible in my file.

I also tried the Command ruled surface but it creates inaccurate surfaces.

any ideas what could solve this problem?


Hi @monika.ladner,

I suppose that you have all upper curves, as well as all lower curves - in the same order as the upper curves -, in two separate, flattened lists. Your lists should have the same number of curves, the same length so to speak!

If so, simply input both curves lists into the first and second input of a Merge component and graft both inputs. The Merge component should now output a tree of two curves per branch, one curve from the upper curves and its corresponding lower curve. You can verify this with a panel!

Simply input this data tree, your reordered curves, to the Loft component and everything should work out fine!

In grasshopper, it is often about organising, restructuring and shuffling your data in order to provide it in the right order for the next component to process.

Next time, try to provide a file!

Hi Monika

P1r4t3b0y had the answer before I could finish my example.

Of course he is correct - you have to feed Loft only the curves required for each surface separately. If you give it multiple curves it will try to make a single surface from all of them.

In your case the Graft parameter is key to getting correct results. It separates the inputs from a single list into separate lists, so when you feed these to Loft it gets 2 curves at a time and can then make the correct results. (6.4 KB)

thank you, was a great help!!
solved the problem now.