Help! Loft problem, surface deformed (Added to prev thread)


#1

Using straight loft to make a surface, but surface doesn’t looks so good.
Also when it is combined the surface gets really funky.

Anything I can do to fix it up?

Problem with Loft.3dm (11.8 MB)


(David Cockey) #2

.The mesh used to display the surface is too coarse. Refine the settings in DocumentProperties > Mesh

“Smooth and slower” will look much better than “Jagged and fast”. If further improvement is needed alter some of the settings in Custom.

If a surface looks odd and there are gaps between the surface displayed and the edge curves then the problem is almost always too coarse a display mesh.


#3

Thanks you @davidcockey It looks much better, but still after joining with other surfaces, it looks dented.


(David Cockey) #4

The “dents” appear to be from too coarse a display/render mesh. Note that the display surface is away from the isocurves. Can you provide a screen shot of the current mesh settings in DocumentProperties > Mesh?


(David Cockey) #5

Also try ClearAllMeshes which will clear all the display/render meshes and put the display into Wireframe mode. The meshes will be recalculated when you switch back to Shaded or Render mode.


#6

Here’s the setting for the mesh.

I did something along the way… it looks ok now.
Thank you for the help.
I’ll play around a bit more.


#7

Still need help in loft getting deformed.
Twisted Surfaces still.

Anyway to fix this up?

Loft_Help.3dm (6.1 MB)


#8

Even doing loft separately then joining turns surfaces to this:


#9

Or try custom settings:


#10

It seems more of problem with loft this time…


(David Cockey) #11

Not a problem with loft. The “render mesh” is too coarse. Use ShowRenderMesh to see the render mesh. The render mesh is used as the input for the display of surfaces. The render mesh is not used to display the isocurves which is the reason the isocurves are as suspected. When the displayed surface appears to be pulled away from the edges or isocurves the cause is almost always due to the render mesh being too coarse.

If the render mesh settings are changed to sufficiently refine the render mesh then the display will appear as you want, but performance may be slow. Go to DocumentProperties > Mesh > Custom > Detailed controls and change the settings until the appearance is acceptable.


#12

Thanks @ferry59 and @davidcockey It seems the update only happened after changing viewport(shaded->wireframe->shaded)


#13

I’m wondering what would be around a good render mesh setting as, in the window it looks ok, but if I for example set it out to STL file, some areas are still squashed.

I was thinking it would just change how it looks on the screen and not the actual dimensons…
(so if person using a less powerful machine can’t get a accurate enough surface…)


STL:

test_output.stl (623.2 KB)


#14

Posting V5 ver. as well.

Loft_HelpV5_.3dm (4.4 MB)

In display looks ok.

Set STL output to 0.001mm tolerance.

Still looks jagged…

LOFTHELP_STL.stl (937.4 KB)


#15

your stl mesh looks ok, in this area its a bit jagged but not so bad, if thats for 3d printing then maybe this might not be noticed too much after slicing it, sometimes i increase the resolution by equalizing the minimum maximum values as seen below this will increase overall file size but will help you to get a finer mesh. its not the best solution but a last resort. i might have to play with it to keep the resolution low while still getting a good mesh.


#16

Hmm… say I output file to iges, that would still create
a crease since it’s translated from nurbs to meshes by rhino?
I’m wondering if it may look good on rhino viewport, but a mess when exported…

I was thinking the smoother and rough was just so rhino can draw it quickly, for viewport sakes. But I guess it’s a preview of what the exported file may look like. as calculated by rhino.


#17

i tried igs and imported to cinema as nurbs, the surfaces looked ok. its really just playing with the mesh settings till you have it acceptable, but dont compare mesh with nurbs in this regards that will never be the same. specifically when you turn on flat shading which reveals what rhino typically shades with some phong or polygon shading whatever its called there. maybe increase the resolution a bit still and give it a try, thats my best guess, otherwise you can blame me for it :smiley:


#18

I’ll keep tryin. :slight_smile:: Thanks.
Maybe I’ll download other cad programs to check how it shows up there.

Maybe I’ll rebuild curves before loft if that helps
with the input.
Just don’t quite grasp what cases the crease while
making the surface in the first place…