Help! IGS file size blowing out



Fairly new Rhino user here, long time A’cad user. First time asking for help. Searched but didn’t find any existing relevant topic.

I have received some 3Mb .stl files. They are closed meshes of molds for RC plane prop.

I was asked to modify and output as a .igs file for CAM.

I made the modifications using Rhino Mesh tools. Then discovered that .igs doesn’t support meshes, needs to be surface (ie closed polysurface).

Converted to surface using Mesh2NURB, got the 20,000 faces warning and proceeded anyway.
No problems, surface seems fine - however Rhino file size, or IGES, has blown out to around 250Mb!

Are there any obvious things I can do to create a radically smaller closed polysurface file, closer to the 3Mb mesh I started with?

Am I doing something wrong? Can I simplify the surfaces without blowing away my curve detail?


The file size is completely normal, with MeshToNurb you have simply created one surface for each mesh FACET, so you now have a polysurface with more than 20K surfaces… this will probably not be good for much.

There is no easy way to go from complex meshes to good quality NURBS - you’re pretty much stuck with reverse engineering the thing and re-modeling.

The best way to deal with this is to find a CAM program that supports meshes so you don’t have to remodel, but that’s not always an option. Otherwise here you will find some info on how to go about remodeling…



FYI…madCAM for Rhino supports meshes.


(Scott Davidson) #4

Converting from Mesh to NURBs properly can be difficult and time consuming. Finding a process that does not require the conversion is probably the best. Since RhinoCAM can machine meshes, that would be a great solution.

You can start to section the plane, rebuild the sections smooth and remodel from those sections. It is time oconsuming, but can give you a very clean model.

There are a number of plug-ins which I have had some sucees with to assist the reverse engineering process. You may want to look at the plug-ins on this page:

I have had success with RhinoResurf, RhinoReverse and Mesh Flow on that page.

One of the probelms with the reverse engineering process on surfaces that are meant to be very smooth is that the scan STl may have noise in the scan. This noise will translate to a bumpy surface. Filtering out the moise can be a real art.


Thanks for the helpful replies guys. You have given me some reassurance that I’m not doing anything drastically wrong and my basic understanding of what’s going on was more or less on track.

I’m just a drafter doing some occasional moonlighting for this client, the RC plane modeller. He’s come up with the mesh files from germany somewhere I think.

On the CAM end of things it’s a Chinese guy using MasterCAM and I don’t think he’ll change either.

So I’m kind of stuck doing whatever I can without much chance to change incoming or outgoing file types!

I requested both original files as surfaces and that the CAM user recheck that STL files really didn’t work. He eventually managed to get STL files working - language barriers means I’ll never know specifics.

Your advice really helped me get my head around the issue for future jobs, thanks.