Help: bug causing rhino to crash before opening

mac
rhino5
(Natasha Hirt) #1

Hi~

I recently attempted to open rhino to finish off my project, when I realised that it would crash moments after opening the application. It would briefly show the opening screen with recent files etc., then disappear without a trace. For about a millisecond before it dies it shows Licenced to: (null) and Serial Number (null) undefined in the left portion of the window.

I have tried restarting my computer several times, downloading and re-installing rhino twice, reset the preference folders, opened it through finder, through terminal, and through desktop shortcuts, and yet problem persists.

If anyone has any advice I would greatly appreciate it, I’m entirely at a loss.

#2

get an app called AppCleaner its free and will delete all the hidden registries either. then do a clean install once more.

or you pick them out by hand. for this go to the upper menubar in finder click goto then hold alt, the library appears, click it. further to application support then to mcneel, trash the entire folder. the licence itself it stored in the outer library of your harddrive there the same go to application support mcneel you know the deal. thats it. from here its just a clean install one last time and you should be rolling again.

(Natasha Hirt) #3

Thanks for your advice. I tried both, and it’s still responding the same way, oddly enough.

#4

i just realised that you are opening the same file, sorry my mistake. that most likely is the problem. if it does not contain any crucial information you can post it here simply drag and drop it into the reply text field, or upload it to tech@mcneel.com and describe the problem.

opening rhino works otherwise? if so open a new empty file then call the command Rescue3dmFile and choose that file, see if it brings you any closer.

(Natasha Hirt) #5

Hm no rhino actually won’t open at all. I’ve attached a video of the problem, maybe that’ll be clearer. https://discourse-cdn-aws1.com/mcneel/uploads/default/original/3X/6/e/6e1c3600225b62f54f16d38a8b364cd59936c862.mov

#6

i see you installed app cleaner, i believe you should activate “delete system files” and “smart delete” from what i remember only then it really deletes all it can associate. otherwise if you delete all above declared files including the application itself of course that should do… be sure to make a restart before reinstalling to flush any possible cached files. if all that does not help i cant help you further, sorry

(Natasha Hirt) #7

thank you so much — I installed another app cleaner which seemed to do a more thorough job. Works fine now (: