Heightfield - how to suppress warning dialog


#1

Hello,
I am frequently using the “_Heightfield” command (in vb script) where I define more than 10.000 control points for the surface creation. As a result a warning dialog is displayed:

“The resulting surface will have 40000 control points… You might run out of memory and crash. Do you want to save your model before proceeding?”, urging me to save the file.

Is there any way to suppress this dialog, i.e. disable the alert? It makes no difference if “_Save” was used before the command.

Thanks.


(Menno Deij - van Rijswijk) #2

Try a dash “-” between the underscore and the command name.

_-HeightField

This will put the command in scripted mode, hopefully disabling the warning dialog.

The dash should work for any command to disable user interactivity and make the command fully scriptable.


#3

Unfortunately, it doesn’t (at least here)… this appears to be hard-coded in there…

–Mitch