Have reinstalled nXt 5 - crashing Rhino



Hi there, I installed nXt 5 a year or so back, but had to disable it due to crashing of Rhino. I’ve just re-enabled it and checked it is up to date, but it is crashing Rhino. If I use the renderer it won’t let me close Rhino, which I can only do with ctrl-alt delete. I think this is the same issue I had a year back, so wondering if it isn’t Flamingo?
I also have Brazil installed, and it is the latest Rhino. Hoping someone may have some suggestions of a fix!

(Brian James) #2

The first thing I’d check is if your Rhino 5 is up to date with service releases. We’re on SR14 now but SR13 should be fine for nXt 5 too. If you still crash after that, did you see a crash reporter and send it in when it happened or is there no crash but just that you had to close Rhino via the task manager? Also check to see if it is file specific or if it happens with any new models.


Thanks @BrianJ,
SR14 installed.

I’ve just reloaded the plugin in plugin manager.

Tried a render and close on an existing and new model and it worked ok.

Opened the control panel and Rhino stopped responding for about 2-3 minutes. It went to a ‘close/wait?’ option, I waited and it made it through.

I turned on a ground plane (probably not relevant), rendered, stopped the render after a minute. Now I’m unable to close Rhino - yes except for Task Manager, so no reporting option.

I hope that is a help!



OK have just opened a new model, no renders or control panel and I’m unable to close. @BrianJ Actually NO commands are working. I can just manipulate the viewport.

(Brian James) #5

Thanks for the extra details. Since you were able to run commands at one point I’m hoping you can close and restart Rhino to try these two commands. The first is TestToggleFileDialog, run that one first when you open Rhino. If it helps, you can add it to your start up commands in Options to be automatically run when Rhino starts. The second command which may help is the SetDpiAwareness command, click the one option in the command line to Disable high dpi scaling of Rhino. This was introduced in SR14 to fix issues for some users and if you disable it you should essentially be back to SR13 behavior. Any luck?


OK it is now trying to close, with a spinning Windows 10 wheel and ‘not responding’, so I can force quite without Task Manager now, but certainly something isn’t right.

I’ll disconnect the plugin for now.


(Brian James) #7

Okay, please try those commands and enable nXt 5 again to see if that fixes it. I’ve seen the need for the testtogglefiledialog command on several user systems after the latest Win 10 1703 update and v5 SR14. Let me know how it goes please.

@JohnM any other ideas?


Yep, that is what I did during the day today. (Aust time) I can try again tomorrow in the office. Ran the commands and then enabled, that is when the error kicked in, but I’ll give it a go.