Has there been change since introducing subD in 7 WIP

I have been exploring subD, however after watching this video (https://www.youtube.com/watch?v=Ipb84RImOX8) at 0:40 the guy uses “Create SubD plane”. Somehow the plane comes out rounded. How is this done?? Looking at all the options for this tool there is no option to round the edges.



SubD’s are naturally rounded based on subdivisions. My guess is you don’t have smooth display mode on. Tab toggles the display of SubDs.

Ahh, I see. Managed to get it fixed!