Gumball Toggle Issue Rhino 7 Wip

Hi everybody in forum.

I’ve tried Rhino 7 wip and I’m facing an issue when I toggle Gumball on-off.
It’s usually stop the program about 28-30 second, after that everything is work normal and if I don’t touch Rhino 7 for a while, this will happen again. Pls check my video record for more details.
Gumball is have no issue on Rhino 5.


Must appricate if everyone can help me to sovle this issue :slight_smile:

Pls check my system report

Rhino 7 SR0 2020-2-18 (Public Build, 7.0.20049.13225, Git hash:master @ b8c41ee41de193a281d1b56fddd30f605dffb7f4)
License type: Commercial, build 2020-02-18
License details: Stand-Alone
Expires on: 2020-04-03

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DES01

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro P2000 (NVidia) Memory: 5GB, Driver date: 12-6-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 441.66

Secondary graphics devices.
Intel® UHD Graphics P630 (Intel) Memory: 1GB, Driver date: 8-15-2018 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-6-2019
Driver Version: 26.21.14.4166
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 5 GB

Rhino plugins
C:\Program Files\Rhino 7 WIP\Plug-ins\Commands.rhp “Commands” 7.0.20049.13225
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.0.20049.13225
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.0.20049.13225
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7 WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.0.20049.13225
C:\Program Files\Rhino 7 WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.0.20049.13225
C:\Program Files\Rhino 7 WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7 WIP\Plug-ins\Displacement.rhp “Displacement”

Can anyone help me in this case ?

Update your Intel 630 driver:

If your computer complains the driver isn’t validated for your computer, here’s how to fix that too:

1 Like

Dear John

Drived is updated but Gumball still have the same problem. :sleepy:

Rhino 7 SR0 2020-2-18 (Public Build, 7.0.20049.13225, Git hash:master @ b8c41ee41de193a281d1b56fddd30f605dffb7f4)
License type: Commercial, build 2020-02-18
License details: Stand-Alone
Expires on: 2020-04-03

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DES01

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro P2000 (NVidia) Memory: 5GB, Driver date: 5-22-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 430.86

Secondary graphics devices.
Intel® UHD Graphics P630 (Intel) Memory: 1GB, Driver date: 9-25-2019 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-22-2019
Driver Version: 26.21.14.3086
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 5 GB

Rhino plugins
C:\Program Files\Rhino 7 WIP\Plug-ins\Commands.rhp “Commands” 7.0.20049.13225
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7 WIP\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.0.20049.13225
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.0.20049.13225
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7 WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.0.20049.13225
C:\Program Files\Rhino 7 WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.0.20049.13225
C:\Program Files\Rhino 7 WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7 WIP\Plug-ins\Displacement.rhp “Displacement”

It looks like you did not use the links to the much newer drivers I supplied.
If you instead used the automatic checking tools, that would explain it.

The current intel driver is from mid January and the nVidia driver is from early February.

1 Like

Hi John

All driver is updated but the problem still there.
Pls be noted I’m using NVIDIA P2000 so driver for this card is newest.
I’m not sure this is a bug or not,just hope that final version will solve this problem.
Anyway, thank for your support.

Rhino 7 SR0 2020-2-18 (Public Build, 7.0.20049.13225, Git hash:master @ b8c41ee41de193a281d1b56fddd30f605dffb7f4)
License type: Commercial, build 2020-02-18
License details: Stand-Alone
Expires on: 2020-04-03

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DES01

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro P2000 (NVidia) Memory: 5GB, Driver date: 7-3-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 431.40

Secondary graphics devices.
Intel® UHD Graphics P630 (Intel) Memory: 1GB, Driver date: 2-5-2020 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-3-2019
Driver Version: 26.21.14.3140
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 5 GB

Rhino plugins
C:\Program Files\Rhino 7 WIP\Plug-ins\Commands.rhp “Commands” 7.0.20049.13225
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.0.20049.13225
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.0.20049.13225
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7 WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.0.20049.13225
C:\Program Files\Rhino 7 WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.0.20049.13225
C:\Program Files\Rhino 7 WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7 WIP\Plug-ins\Displacement.rhp “Displacement”

Hi - This is not something that we are seeing on other systems and not something that will disappear by itself.

How about in Rhino 6?

Even though you are running with updated drivers, a Windows update might have messed with those and could result in something that you are seeing on your system.
I would try to completely uninstall all GPU drivers and then install the very latest.
There’s a guide for doing this here:


Make sure to include step 4 of the uninstalling process!
-wim

1 Like