Gumball Rhino 8 WIP can't extrude (no Solid) by Number Value

Gumball Rhino 8Wip can’t extrude
(in no Solid or BothSide)

by Numbering Value
I Test the wip version that handles gumball removed ;
in This Version :sunny:
Ctrl+ drag= extrude (no Solid)
SHift + drag= extrude BothSide
But in Numberic modeCtrl and ShiftCan’t work

1 Like

The gumball works as expected in Rhino 8 SR0 2023-5-16 (Rhino WIP, 8.0.23136.12095)

Maybe you can upload a screen video and a Rhino file showing your problem?

If the curve isn’t planar, the extrusion is not going to be closed.

In new update if we will want extrude numberic +both Side by shift key or extrude +and NotSolid +numberic
Disable it!

It seems the extrusions are closed when the curve is closed and planar.

I would also prefer open extrusions. If the open surfaces are planar, it’s easy to run the cap command. Deleting faces requires a selection and is more of an effort…

@martinsiegrist - Currently you can make open or closed extrusions from your closed curve by:

  1. Drag on Extrude Dot = Closed Extrusion
  2. Drag + Ctrl on Extrude Dot = Open Extrusion
    Does that help?

That’s ok for now.

However I’m not sure if it should be the opposite. A simple drag on the extrude dot would lead to an open extrusion consistently.

If the curve isn’t planar, the extrusion is always going to be open.

Drag = open extrusion

Drag + control = closed extrusion

If the curve isn’t planar, ctrl has no effect and the extrusion is open.