Groove appeared in mass after sweep

Hello, I’m Beshoy, this is my first post on this forum. I just started using Rhino and I intend to use it mainly for jewelry and for some architecture visualization anyway I started watching some tutorials on ring making and I was sweeping these

and then I made the direction to the left

When I pressed enter I found like a small channel or groove in it.

What am I doing wrong? By the way I tried the automatic and natural options and they had even more problems. Thanks in advance.

Another question: Is there anything I should be aware of since the beginning when I want to 3d print my models?
Sorry I didn’t know which category I should put this post in.

It is much easier to diagnose problems if the .3dm file with the model is available. You can upload the file by clicking on the vertical arrow icon in the row of icons above where you type posts.


1 Like

Oh thanks davidcockey I didn’t know that :smiley: here’s the file, it has 2 rings, it’s the complete closed one that has the groove on the side as I mentioned.Ring.3dm (691.3 KB)

It’s Rhino 5 by the way so if you wanted me to convert it just tell me. Thanks for your help :slight_smile:

Hi Bishoy - I guess the problem is that you are mixing curve types in the cross sections - it gets a bit geeky, but the top curve is made up of four nice, degree 3 four-point curves, plus the little arcs at the corners. The bottom curve is made of all arcs- arcs are special in that they are rational and some of them here have multiple spans (more than 3 points for a standard arc in Rhino) Sweep has to combine and align the curves as best it can and the result is, well, imperfect as you see. The easy way out is to use the ‘Refit within’ radio button in the Sweep1 dialog - that way Rhino will not try to pay attention to the curve structure and will create new curves instead for the purposes of the sweep.


1 Like

Hi Beshoy,

To eliminate that specific crease, you can also delete the highlighted control point:


1 Like

Hi Pascal and Steve, your suggestions solved the problem thank you very much :smiley: