Grid only show on part of surface

I’ve created a surface in gh by the revolving command. When I try to use paneling tool on the surface to create a equal grid across the surface, somehow the result only shows on part of the surface. Can somebody tell me why is this happening? Thank you very much.



panellingtool-qustion.gh (7.6 KB)

Hi @xshan
You need to set a reference point that makes sense in relation to your surface. Here I’ve set the mid-point of the rail curve, which gives a more even distribution.


panellingtool-question_JN.gh (11.6 KB)
HTH, Jakob

1 Like

Hi @Normand
Thank you for the reply. That makes a lot more sense.
However when I tried to open the file you uploaded and I’m seeing different result from yours.


Any ideas why?

Hi @xshan
No idea, sorry. Just tired to download the file I uploaded to makes sure that it wasn’t faulty in any way, and I still get the “right” result here. Is both your Rhino and Paneling Tools up-to-date? If yes, you could try and run SystemInfo and post the result here - it can sometimes give some pointers as to what is wrong.
HTH, Jakob

Hi @Normand
I have rhino 6 and I just recently downloaded paneling tool. (Not really sure it’s the best version for rhino 6 or not) Here’s the result for SystemInfo. Thank you.

Rhino 6 SR35 2021-8-10 (Rhino 6, 6.35.21222.17001, Git hash:master @ 073ac7b225c67348731c6597127b9410126c3139)
License type: Commercial, build 2021-08-10
License details: Cloud Zoo. In use by: Xiaoton Shan (SBA)

Windows 10.0.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: SBA47

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 1050 Ti (NVidia) Memory: 4GB, Driver date: 9-30-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 456.71
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-30-2020
Driver Version: 27.21.14.5671
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.12.17.906\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 6.35.21222.17001
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\Lumion LiveSync for Rhino (839d6175-32d1-4ffe-a0a4-b7fb43cf0ff5)\2019.11.5.949\Lumion\Rhino 6.0\LumionPlugin.rhp “Lumion LiveSync for Rhino”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\NamedPositions.rhp “Named Position”

Hi @xshan
Ah, V6! Just tested in V6, and I get the faulty result as well. @rajaa - is that a V6 bug or is it something that can be adjusted?
-Jakob

Yes, this bug was fixed in V7, and there is no plan to fix in V6.