GrasshopperPlayer still running in background

Hello,

I want GrasshopperPlayer to execute my script only once, currently it stays in grasshopper cache and update itself on component change.

Joined a simple script that get a block’s Id and place a text at the box center point.
When I call that script from the _GrasshopperPlayer Rhino command it works, BUT when I move the object, the scripts updates itself, and the text is bake again.

I figured out that when I disable the solver, it’s working perfectly fine, but I it’s really anoying to keep the solver disable.

Are they any way to make the solution expire just after it’s execution ?
Maybe something with scheduling solution ?

Otherwise, do you plane to make a getBlock component one day ?

I know that this problem has certainly been solved when the grasshopperPlayer is turned into a command using the RhinoScriptCompiler (! _Run RhinoScriptCompiler).

I found a solution ! To launch the script from another grasshopper. See here

I’ve explored as well hops plugin.
https://discourse.mcneel.com/t/about-the-hops-category/

But it is not really fitting my need

Here is another version of this grasshopper using python script instead of an external plugin
text_only_once-ghp_cache_issue.ghx (78.7 KB)