Grasshopper UI scale has changed

Sometime in the last two months scaling of the entire UI has changed so that my Toolbars and Component Tabs have become very small, and they are much smaller than the corresponding UI items in Rhino.

In addition, my GH files that had been nicely formatted now have components that are much larger than before, resulting in an ugly look.

I recently converted from Windows 10 to Windows 11, so I suspect the problem arises from that change.

Attached is a screenshot showing GH and Rhino side-by-side, suggesting that this is a GH-only problem.

I’m hoping there is an XML setting that I can reset or change somehow.

Bill

Your GH canvas says 163% which makes the components much bigger than at 100%.
Zoom out!

Zooming never changes the size of a component relative to the canvas space in which it sits. Zooming in and out on this canvas perfectly preserves my uglified layout.

Show us a screen shot of components on the canvas at 100%?

About those green lines on your components though…?

Is that image your actual screen size? (994 X 868 pixels) This is mine: (1920 X 1080 pixels)

Mine is 1920 by 1200. Note how much smaller, compared to yours, my component icons look in the Component Tabs, and everything else in the toolbars.

Note: This isn’t due to a Windows setting because the Rhino toolbars look fine.

Yeah, I see your point now. This is yours at the top, mine below:

Note: I’m using Rhino 7.35

I tried Repair in Win11 Apps, Installed Apps → No change
Also tried a full Uninstall/Install → No change

If this helps with diagnosis:

I installed Rhino 8 and GH looks correct.

I’m stuck because:

  • I can’t upgrade to Rhino 8 yet without a whole lot of company and server updates.
  • I can’t share Rhino 7 files with other team members due to Canvas formatting mismatches.

Somehow as part of my conversion to Windows 11, I seemed to acquire a “Custom Scale Factor” in Settings, Display.

I eliminated that and now all is well.

Weird that it affected Rhino and GH so differently.

Bill

2 Likes