Grasshopper runs when I enable components one by one but doesn't when whole definition is run

If I run the definition enabling nodes one by one it takes ~2 minutes to run. (including the time I enable the items) However, if I try to run the whole file, it never runs. I have waited over 40 minutes and it is frozen. I have uploaded some of the documents from the file, but the file paths would need to be updated, of course.For Forum.gh (12.6 KB)
graphs 01.txt (3.1 MB)
labels 01.txt (514 Bytes)
Processing: 1.0.brep…

I experience the same problem… working definition, no problems and then the next time I start rhino + gh its frozen without any reason:

I’m using kangaroo and custom components but when I run it from VS in debug mode it should throw an exception, but there is none. Rhino (7.14)

Whats worst for me is I cant make it run again…
is there a way to purge the gh file or something like refresh?
Very strange and annoying! I hope someone here can think of why this is happening

Edit:
Found the culprit and as expected was my code. Conclusion: Never code while loops when you are tired!