Grasshopper quelea

grasshopper

#1

Hi guys. I am trying to use quelea as a visualisation mechanism for master plan and interior building flows.

Although i have used this plugin in the past and it has worked just fine for contain and avoid obstacle behaviours, recently whenever i use a brep as a base geometry for an environment or

an obstacle i get the ‘solution exception, method not implemented’ error, and/or the object not recognised. I have attached a very simple particle scene, where the problem arises.

Originally i though it was a bug caused by grasshopper as seen here:

However, i downloaded the tryout of rhino 6 (i had version 5), and again i am getting these errors.

Kind regards,

Theofano.

\ 64x64 Error: "Solution exception:Object reference not set to an …

Hey, all. I keep running into one particular issue: when I reopen a (previously) functioning definition I receive the following error for the Kangaroo Physics…ERROR.gh (22.0 KB)
ERROR.3dm (268.3 KB)
ERROR.gh (22.0 KB)
ERROR.3dm (268.3 KB)


(David Rutten) #2

Some generic error message information:

Object reference not set to an instance of an object is a programming bug. The programmer is trying to use an object which doesn’t exist. It is usually solved by adding a check to make sure the object exists and then take proper evasive action.

Method not implemented however means the programmer is calling a method in someone else’s code which isn’t there. The problem here is that the programmer used a different version of the other code than you are. Either the plug-in was ‘build against’ a newer version than yours of whatever the other code is and this method was only recently added, or it was build against an older version than yours and this method was removed in the interim.

The latter case is called a ‘breaking change’ and it is something we try to avoid at RMA, except between major releases of Rhino, say 4 vs. 5.


I installed the Agent plug-in from Food4Rhino, however your gh file contains an Agent component which is not available in the latest version:

So I cannot open and test your file.