Grasshopper Plugin do not load

I was trying to install a few plugins (weaverbird and ngon) in grasshopper but suddenly GH broke down. I couldn’t install WB neither ngon by packagemanager.


Captura de pantalla 2022-05-17 202640


I’ve just unistalled RH and everything the same. Plz help

Hi Amaro -
When you check the plug-in manager, what happens when you enable Grasshopper and then restart Rhino?

it’s enabled but not loaded

When i click on “load plug-in”…


Hi -
Did you use the PackageManager to attempt to install those two plug-ins? If so, please see if you can uninstall them from the PackageManager.
If you installed them manually, I’d look for files related to these plug-ins and delete them.
Finally, I’d try to run a Repair on the Rhino installation from the Windows Control Panel.

I’ve just tried to run the PackageManager command but it didn’t work. (It doesn’t work anymore)
I couldn’t install Ngon/Wb so there’s no any file. Food4Rhino automatically opens RH and PackageManager but it doesn’t work with both plug-ins.

Recently I tried to ‘repair’ RH but nothing happened.


Hi -
Please run the Rhino SystemInfo command and copy-paste the result here.

Rhino 7 SR18 2022-5-4 (Rhino 7, 7.18.22124.03001, Git hash:master @ b2a1120bcb32e1f6da66a421cd7162a18a9f0cd9)
License type: Educacional, build 2022-05-04
License details: Cloud Zoo

Windows 10.0.19044 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [85% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 1050 (NVidia) Memory: 2GB, Driver date: 4-20-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 512.59
> Integrated accelerated graphics device with 1 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

Secondary graphics devices.
Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 4-29-2022 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-20-2022
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 2 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7-v2\Plug-ins\Commands.rhp “Commands” 7.18.22124.3001
C:\Program Files\Rhino 7-v2\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7-v2\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.18.22124.3001
C:\Program Files\Rhino 7-v2\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.18.22124.3001
C:\Program Files\Rhino 7-v2\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7-v2\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7-v2\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.18.22124.3001
C:\Program Files\Rhino 7-v2\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.18.22124.3001
C:\Program Files\Rhino 7-v2\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7-v2\Plug-ins\Displacement.rhp “Displacement”

This is from command window


Hi -

I take it that the PackageManager command still works?
Could you post a screenshot of the “Installed” tab in that dialog?

Nope, PackageManager doesn’t work. When i run the command nothing happen.
About “installled tab” i’m not sure what you mean :disappointed_relieved:

Hi -

What does the command line say when you run that command?

It sounds like something got seriously messed up on you computer and it’s weird that a Repair doesn’t fix that. A long shot, but I’d try changing the update frequency to the release candidates and get Rhino to download and install the latest candidate.