Grasshopper, no mousewheel click possible and python is lacking

I cannot use my mousewheel to click in Rhino 6/Grasshopper. It there an enable option?


Also, my Python is lacking when typing rs.[…]; no info nor ‘suggestion’ is shown.

don’t know what’s the problem, but the (temporary) solution would be using the “Space” button.

Thank you for your response.

About the “Space” button, even that would not work, also, Python in grasshopper is lacking. When typing rs. it does not fill for me nor do I see the instructions in the window underneath.

ok, so its not an issue with the mouse or with the mouse events, seems more a problem with the gui of grasshopper. Usually Grasshopper should work stable, haven’t seen any report of this in the forum before. So maybe some plugin or one of your Python scripts are causing the issue? Maybe you just remove plugins from the pluginfolder and test if the problem still occurs. If so it might be a rare bug of Grasshopper, but I bet this is rather an issue with third party plugins, or unlucky scripting.

I re-installed everything, so there is no ‘old stuff’ anymore. Now it seems to work.

And for the guys that have a problem with the middel mouse wheel: Ctrl + Shift

As in “that re-enables it” or “it will work as long as you press Ctrl+Shift”? Is that some sort or Windows setting? I know that if I press Ctrl+Shift my keyboard switches input mode from EN-US to EN_UK.

No, sorry, what I meant was:

Ctrl + Space_Bar

That language switching shortcut is the very first thing I disable. With programs in use that do something very useful with this modifier keys enabled switching languages and key layouts is a major PITA.